12

After upgrading to 13.04, I get this error and other answers (Optirun glxgears: Cannot access secondary GPU - error: [XORG] (EE) No devices detected, 'Cannot access secondary GPU' error with Bumblebee) didn't help.

dpkg -l | grep nvidia

ii  bumblebee-nvidia                              3.2.1-1~raringppa2                          amd64        NVIDIA Optimus support using the proprietary NVIDIA driver
ii  nvidia-310                                    310.44-0ubuntu2                             amd64        NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-settings-310                           310.44-0ubuntu1                             amd64        Tool for configuring the NVIDIA graphics driver

This is my /etc/bumblebee/bumblebee.conf: http://pastebin.com/G9R55VMr

This is /etc/bumblebee/xorg.conf.nvidia: http://pastebin.com/9xNUPp6b

This is /etc/modprobe.d/blacklist.conf: http://pastebin.com/tCnSCz0B

This is /etc/modprobe.d/bumblebee.conf: http://pastebin.com/WtX1LR9d

This is /etc/modprobe.d/nvidia-310_hybrid.conf: http://pastebin.com/CbVg2FN1

My /etc/bumblebee/xorg.conf.d folder contains only 10-dummy.conf file, that is empty.

This is /var/log/Xorg.8.log: http://pastebin.com/iSMXT7aE

This is optirun -vvv glxspheres output: http://pastebin.com/rbyUhRNr

Ask for further details, if needed!

9
  • 1
    output of optirun -vvv glxspheres ??
    – Qasim
    May 4, 2013 at 7:53
  • 1
    DO you have a /etc/bumblebee/xorg.conf.d/ directory? Please post the contents of the files in that directory as well as /var/log/Xorg.8.log.
    – Lekensteyn
    May 4, 2013 at 8:28
  • Edited with both requests! Thank you for your help!
    – jasmines
    May 4, 2013 at 13:24
  • how did you install bumblebee ?
    – Qasim
    May 4, 2013 at 13:36
  • sudo apt-get install bumblebee virtualgl linux-headers-generic
    – Qasim
    May 4, 2013 at 13:37

4 Answers 4

15

The following AskUbuntu answer fixed it for me: https://askubuntu.com/a/285638/47280

Basically, you need to edit /etc/bumblebee/xorg.conf.nvidia and uncomment the following line:

BusID "PCI:01:00:0"

In the config, it states that this is necessary for Ubuntu 13.04. This number refers to the BusID of your GPU, so if it's different then go to the other answer for full instructions.

1
  • Anyone using a Lenovo ThinkPad T420 will need this answer!
    – Peaches491
    Sep 17, 2013 at 3:25
3

I found the following file:

/usr/share/X11/xorg.conf.d/10-nvidia-current-latitude-e6530.conf

I deleted it and optirun worked!

3

In /etc/bumblebee/xorg.conf.nvidia , uncomment

BusID "PCI:01:00:0"

and replace with

BusID "PCI:0x:00.0"

where x is the number that you see in 'lspci' list next to 3D controller, which should be your nvidia card

3
  • ... and this worked?
    – pix
    Mar 22, 2014 at 7:23
  • yes and no - it fixed problem with non existed secondary GPU, but did not make a solution (work is unstable and has issues with sleep mode) Mar 31, 2014 at 15:37
  • @MaximSinev Did you fix the sleep error? Aug 30, 2016 at 18:30
1

Well I had same problem after upgrade and nothing I found helped. I had newest version (3.2.1) installed, because I re-added ppa after upgrade and updated bumblebee.

I did one stupid thing though: I removed ppa with ppa-purge and removed bumblebee. Then I added ppa and installed bumblebee again. And magically it started working (at least after reboot). I can't really tell you why though...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.