I've installed Ubuntu (almost all latest versions), when my Acer Aspire V5-471 is want to shutdown from Ubuntu, it acts as restart/reboot. Refer to edit 2 for releases tried and edit 1 for tried derivatives.

edit 1: It's happens on 2 versions (till now), Ubuntu and Ubuntu Studio/Xubuntu (both Ubuntu-studio and XFCE session).

edit 2: Same as edit 1 (only for live-user, others only uses Ubuntu), happened on Normal installation (12.04 to 13.04), Wubi installation (12.04 only), and Live User Session (12.04 to 13.04).

Rebooted after short shutdown time even as root or sudo-ing from this command :

shutdown -h now

Why? Can I fix this?

  • Can you tell us what is actually happening? So what do you do to start the "shutdown", what do you see on your screen, etc. YOu can also check your syslog for messages.
    – Nanne
    May 4 '13 at 6:42
  • Not enough information is provided. There is a translucent popup right? Which did you click?
    – owl
    May 4 '13 at 6:47
  • @owl I just click shutdown.
    – Aryo Adhi
    May 4 '13 at 6:51
  • @AryoAdhiWibisonoLegopermono What about you do 'sudo shutdown -h' on Terminal?
    – owl
    May 4 '13 at 7:23
  • I'll try it... i'll recomment if that successfull
    – Aryo Adhi
    May 4 '13 at 7:29

Upgrading the mainline 3.9 kernel appears to solve it.

See here for installation direction.


This is true in Debian, I assume the same is true in Ubuntu.

shutdown takes arguments in order to achieve specific events. I guess in Ubuntu, they made the default for shutdown an alias to shutdown -r now (-r for restart, now for, well, now). If you want to halt the system, or shutdown, do shutdown -h now (-h for halt) and that should do what you want.

  • tried and keeps reboot... running as root
    – Aryo Adhi
    May 14 '13 at 5:19
  • shutdown -h now does? Perhaps the above user is correct then, the -h switch should never cause a reboot, that should be a halt
    – Seth Curry
    May 14 '13 at 13:19
  • I don't know what's happening on my notebook, and it's always REBOOT even running it as root or sudo-ing first... Going to record and upload to YouTube.
    – Aryo Adhi
    May 14 '13 at 13:46
  • According to this from the Mint forums which should be running the same base, this is due to a Wake on LAN error, try disabling your wireless in the BIOS and then rebooting and try it again. According to them shutdown works fine, but WoL is triggering a power on as soon as you shut down, making it seem like a reboot.
    – Seth Curry
    May 14 '13 at 15:25
  • Already disabled, but won't shutdown. I think it's hardware-specific problem.
    – Aryo Adhi
    May 17 '13 at 14:09

No its not hardware specific problem, it happens on my 3 laptops with different hw. I even just upgrade kernel to 3.16 but it still happens. The only way i found to actually shutdown, is before shutdown your computer just disable wlan0, then shutdown normally and voila. but on next start you will have to activate it again. BTW:- Antix, Neptuno, Debian KDE and Arch, can shutdown my laptops with out problem, and using 3.13.xx kernel. So i think the issue is not in the kernel.

Slackware, Ubuntu (K,X,L,S), Mint (C, M, K), Fedora cant shutdown, just reboot. I didnt try LMDE yet, but as is Debian Based, im just wondering it will works fine.


The shutdown command does not work if wake on lan is enabled in the bios. If you have to use wake on lan use halt -p instead of shutdown.

Alternatively you can use the following to shutdown your system

sudo poweroff

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.