I'm installing Ubuntu 12.04 LTS on my Lenovo y500 with nvidia geforce 750M using uefi. What I've done so far

  1. Regular install with Ubuntu disc. (through legacy)
  2. Boot repair (recommended) (through legacy)
  3. Boot up in UEFI to OS selection screen

When I boot up I get the OS selection screen, but when I select the ubuntu choice, my screen is stuck on a purple screen.

Nothing responds, no F2, Ctrl+Atl+F1, Esc, nothing.

I've tried the following solutions, but have no luck:

  1. Updated Nvidia drivers: http://www.dedoimedo.com/computers/ubuntu-quetzal-nvidia.html That got me to the screen with the ubuntu logo and the dots, but soon after crashed into a black screen with commands. I can also no longer access login terminal via boot recovery

  2. Edited boot command: gfxmode nomodeset did nothing for me

  3. Tried to regular boot through recovery: Got to black screen with login terminal. Could login to access system, but still does not boot to regular ubuntu.

  4. Stuck on purple screen: Nothing changed.

  5. Tried nvidia answer: Unable to install Ubuntu on Lenovo Y500 With this, regular choice boots directly into login terminal, no gui or purple screen freeze.

    1. Tried sudo nvidia-xconfig. Did not visibly change anything.


  1. I am booting in UEFI
  2. I did disable srt
  • I,too, am getting a Y500 soon. This is an issue that I'd like to see the answer to as well so that I know what I'm getting into ;) The hardware of the Y500 at first glance looks pretty plug-n-play in Linux (go Lenovo!), the only issue I see is with the UEFI BIOS. Unfortunately, I don't have an answer for you. You installed Ubuntu in BIOS-compatibility (legacy) mode, and then turned UEFI back on? Or is it still in Legacy mode? FWIW, a while back I isntalled Ubuntu on buddy's MacBook. Didn't fiddle with the UEFI or anything and it came out just fine. Just had to hold CTRL on boot or something. – Chuck R May 3 '13 at 22:37
  • Also, did you disable Intel Smart Response Technology (SRT) in UEFI? The 16GB SSD that comes with the Y500 acts as a very large hard drive cache (essentially) if it's reading from this it may not have all the boot files cached already (as far as I know). On the Ubuntu Help page for UEFI, step 2 is to disable SRT. Also of note: from the UEFI help page it states that only the 64-bit version does UEFI detection. – Chuck R May 3 '13 at 22:51
  • It is ok to answer your own question. This allows you to set the checkmark so the question shows up with an accepted answer in lists etc. – Thorbjørn Ravn Andersen May 6 '13 at 7:39

[SOLUTION - Dual Boot Windows + Ubuntu]

  • I got my ubuntu working, but there are some things wrong with it.

  • First, because it's a Lenovo Y500, not all the drivers need will be automatically download or even be available so some things won't work (i.e. ethernet port, brightness adjust, unity?, etc).

  • Second, hibernate works half the time, still don't understand what causes it to work/fail. Suspend does not work for me at all (suspend works, but can't wake up correctly)

  • So if you are considering using Ubuntu, I would recommend against choosing the Lenovo Y500, at least for now.

  • Now the solution (starting from Windows only):

    1. Go to BIOS upon startup F2

    2. Go to the Security menu and turn off Secure Boot

    3. Go to the Boot menu and change boot mode to Legacy AND choose to boot UEFI first

    4. Save changes and restart

    5. After restart, select to boot (F12) into the Ubuntu system via USB or CD.

    6. Select Try Ubuntu (both times).

    7. Then install Ubuntu normally with the install program, but DON'T restart.

    8. After the installation, do Boot Repair: https://help.ubuntu.com/community/Boot-Repair and select the recommended option.

    9. After boot repair is finished you can restart and you should be able to get into Ubuntu and/or Windows

The KEY, I found after trying for two days, is to set Boot Mode to Legacy, BUT boot UEFI first and Legacy Second.

Hope this saved you guys from hours of pain.

  • Upboats for you, and if anyone has trouble booting windows after this process, use the below place for assistance configuring grub. Worked for me. falstaff.agner.ch/2012/12/18/… – a sandwhich Jul 4 '13 at 4:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.