I tried creating a live USB with the default Ubuntu disk creator and the Windows version of Universal-usb-installer and they both work fine except persistence doesn't seem to work.

For example, I change the background image, reboot, I selected the "try Ubuntu" option again at startup and the background is the default. Same with installed packages.

Am I doing something wrong?

Edit My computer did not came with any OS preinstalled. It's an Asus P9X79 in case it matters.


Are you on a UEFI machine booting 64 bit versions of 12.04.2, 12.10, or 13.04? If so you may be experiencing bug 1159016. Feel free to add yourself to the 'Does this affect me' list in that case. Presuming you really created the USB with persistence, you may manually turn it on by editing the /boot/grub/grub.cfg file on the stick, adding the word persistent to the kernel line you ate booting.

  • tried ending the Try Ubuntu with --persistent but still no persistence.. – Inuart May 4 '13 at 13:28
  • The lines in grub.cfg are the linux lines: linux /casper/vmlinuz.efi persistent file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash -- – ubfan1 May 4 '13 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.