I was having problems connecting to the internet either by wireless or wired connection. I keep getting an icon in the systray that has a tooltip that says "unmanaged" and when I click on it I get a "Network management disabled".

I googled and found the command:

sudo dhclient eth0

Which finally enabled my network and I have net. The problem is I still get the icon with the some word "unmanaged"

Can anyone help me out? I just want to know what is happening and why did I had to go to the command line to enable my network.

I had to put the computer in sleep mode and then it wouldn't wake up, so I rebooted the machine. The network manager problems started again, this time the file mentioned by maco had the value set to true and it still wouldn't work.

Anyone know how I can make this permanently work? I did a

sudo init 0

And when I booted the machine at a later time I had the network manager enabled. Have no clue why.


7 Answers 7


I find this happens after a bad shutdown. Just change




in /etc/NetworkManager/nm-system-settings.conf

Note: In newer versions of Ubuntu, the file is at /etc/NetworkManager/NetworkManager.conf

  • Thanks so much!!! I edited the file, rebooted and it worked great :) Thanks!!!!!!!!!!!
    – AntonioCS
    Aug 23, 2010 at 16:16
  • 3
    maco's solution now requires editing of /etc/NetworkManager/NetworkManager.conf. The setting is still the same.
    – Kenny
    May 16, 2012 at 2:30
  • 1
    This solution doesn't work for me in 16.10. Apr 12, 2017 at 6:59
  • 1
    worked for me 18.04
    – Sudheera
    May 11, 2018 at 7:38
  • 1
    Instead of rebooting, service network-manager restart will also work. Nov 25, 2018 at 21:01

This worked for Ubuntu 17.04

sudo touch /etc/NetworkManager/conf.d/10-globally-managed-devices.conf
sudo service network-manager restart
  • Oh jeez this had been plaguing an installation of Bionic I did on ZFS using debootstrap for hours, I was beginning to think nothing would ever work. THANK YOU!!! Apr 23, 2018 at 10:43
  • worked also on Ubuntu 18.04 in which the NetworkManager suddenly stopped. Sep 18, 2018 at 18:13
  • 1
    Thanks, worked for me. Ubuntu 20.04. Probably bad Software Updater package caused no wired connection...
    – Tarasovych
    Sep 22, 2020 at 20:03

I've just upgraded from Ubuntu 16.04 to 16.10. After that, this problem started to happen to me. In my case, I've solved it following the suggestion given in Ubuntu's launchpad:

touch /etc/NetworkManager/conf.d/10-globally-managed-devices.conf

This creates an empty file.

  • 1
    I had the same problem and only this helped me!
    – user307975
    Apr 13, 2017 at 18:46
  • Thanks, this helped me finally fix this problem after an upgrade to 17.04. Apr 16, 2017 at 9:34
  • Thanks, this was the only solution that worked for me in 18.04
    – adamgy
    Jul 6, 2020 at 21:41

You should look at the contents of the file /var/lib/NetworkManager/NetworkManager.state. It should look something like this:


Change any from 'false' to 'true' to re-enable networking. It may work better if you first stop NetworkManager:

sudo stop network-manager

And start it again once done. Or reboot :)

In any case, this is frequent when a suspended system fails to wake up. It should be fixed in Maverick.

  • +1 Massive help for me... Thx. Countless hours fiddling with network settings until I decided to hit the stack exchange. Silly me.
    – Russ
    Dec 19, 2010 at 2:44
  • This! I've been stuck on this all day! Thanks!
    – assafmo
    Dec 1, 2017 at 13:48

I just upgraded from Ubuntu 16.04 to 16.10. I have 3 network cards (all configured) and no Wifi. All 3 cards were disabled, all options on the Network Manager menu were greyed out, so clicking them does nothing. I fixed it by combining two of the solutions above:

Edit /etc/NetworkManager/NetworkManager.conf and change:




Restarted network-manager:

sudo service network-manager restart

No change. Then I tried:

touch /etc/NetworkManager/conf.d/10-globally-managed-devices.conf
sudo service network-manager restart

All three network cards came back on-line.

  • the fix is weird, and the post above is not exactly correct.
    – rob grune
    Apr 21, 2017 at 5:09
  • After a lot of research this was the only one that worked for me. Thanks!
    – six2dez
    May 30, 2019 at 12:10

Try right-clicking the NetworkManager icon and enabling the network from that menu.

  • 1
    It doesn't work. I just get a "Network management disabled"
    – AntonioCS
    Aug 24, 2010 at 8:41

I installed ubuntu-gnome-desktop to ubuntu server 14.04.4 and the file was not nm-system-settings.conf, but NetworkManager.conf

As in sudo gedit etc/NetworkManager/NetworkManager.conf I could not find nm-system-settings.conf Perhaps it is not installed (nm-system-settings) as I do not see it on the gnome Panel bar in the gnome classic view desktop. Need to get the Network going to do updates and install gnome-session-flashback to get the Gnome-Flashback (Metacity) on 14.04.4 LTS, my Favorite desktop!

I had not checked /var/lib/NetworkManager/NetworkManager.state before reboot but, perhaps it was updated after reboot as it was correct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.