15

I was having problems connecting to the internet either by wireless or wired connection. I keep getting an icon in the systray that has a tooltip that says "unmanaged" and when I click on it I get a "Network management disabled".

I googled and found the command:

sudo dhclient eth0

Which finally enabled my network and I have net. The problem is I still get the icon with the some word "unmanaged"

Can anyone help me out? I just want to know what is happening and why did I had to go to the command line to enable my network.

I had to put the computer in sleep mode and then it wouldn't wake up, so I rebooted the machine. The network manager problems started again, this time the file mentioned by maco had the value set to true and it still wouldn't work.

Anyone know how I can make this permanently work? I did a

sudo init 0

And when I booted the machine at a later time I had the network manager enabled. Have no clue why.

22

I find this happens after a bad shutdown. Just change

managed=false

to

managed=true

in /etc/NetworkManager/nm-system-settings.conf


Note: In newer versions of Ubuntu, the file is at /etc/NetworkManager/NetworkManager.conf

  • Thanks so much!!! I edited the file, rebooted and it worked great :) Thanks!!!!!!!!!!! – AntonioCS Aug 23 '10 at 16:16
  • 2
    maco's solution now requires editing of /etc/NetworkManager/NetworkManager.conf. The setting is still the same. – Kenny May 16 '12 at 2:30
  • 1
    This solution doesn't work for me in 16.10. – user1063287 Apr 12 '17 at 6:59
  • 1
    worked for me 18.04 – Sudheera May 11 '18 at 7:38
  • 1
    Instead of rebooting, service network-manager restart will also work. – aggregate1166877 Nov 25 '18 at 21:01
9

This worked for Ubuntu 17.04

sudo touch /etc/NetworkManager/conf.d/10-globally-managed-devices.conf
sudo service network-manager restart
  • Oh jeez this had been plaguing an installation of Bionic I did on ZFS using debootstrap for hours, I was beginning to think nothing would ever work. THANK YOU!!! – AveryFreeman Apr 23 '18 at 10:43
  • worked also on Ubuntu 18.04 in which the NetworkManager suddenly stopped. – Tal Sep 18 '18 at 18:13
7

You should look at the contents of the file /var/lib/NetworkManager/NetworkManager.state. It should look something like this:

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

Change any from 'false' to 'true' to re-enable networking. It may work better if you first stop NetworkManager:

sudo stop network-manager

And start it again once done. Or reboot :)

In any case, this is frequent when a suspended system fails to wake up. It should be fixed in Maverick.

  • +1 Massive help for me... Thx. Countless hours fiddling with network settings until I decided to hit the stack exchange. Silly me. – Russ Dec 19 '10 at 2:44
  • This! I've been stuck on this all day! Thanks! – assafmo Dec 1 '17 at 13:48
6

I've just upgraded from Ubuntu 16.04 to 16.10. After that, this problem started to happen to me. In my case, I've solved it following the suggestion given in Ubuntu's launchpad:

touch /etc/NetworkManager/conf.d/10-globally-managed-devices.conf

This creates an empty file.

  • 1
    I had the same problem and only this helped me! – user307975 Apr 13 '17 at 18:46
  • Thanks, this helped me finally fix this problem after an upgrade to 17.04. – FrontierPsychiatrist Apr 16 '17 at 9:34
5

I just upgraded from Ubuntu 16.04 to 16.10. I have 3 network cards (all configured) and no Wifi. All 3 cards were disabled, all options on the Network Manager menu were greyed out, so clicking them does nothing. I fixed it by combining two of the solutions above:

Edit /etc/NetworkManager/NetworkManager.conf and change:

managed=false

to

managed=true

Restarted network-manager:

sudo service network-manager restart

No change. Then I tried:

touch /etc/NetworkManager/conf.d/10-globally-managed-devices.conf
sudo service network-manager restart

All three network cards came back on-line.

  • the fix is weird, and the post above is not exactly correct. – rob grune Apr 21 '17 at 5:09
0

Try right-clicking the NetworkManager icon and enabling the network from that menu.

  • 1
    It doesn't work. I just get a "Network management disabled" – AntonioCS Aug 24 '10 at 8:41
0

I installed ubuntu-gnome-desktop to ubuntu server 14.04.4 and the file was not nm-system-settings.conf, but NetworkManager.conf

As in sudo gedit etc/NetworkManager/NetworkManager.conf I could not find nm-system-settings.conf Perhaps it is not installed (nm-system-settings) as I do not see it on the gnome Panel bar in the gnome classic view desktop. Need to get the Network going to do updates and install gnome-session-flashback to get the Gnome-Flashback (Metacity) on 14.04.4 LTS, my Favorite desktop!

I had not checked /var/lib/NetworkManager/NetworkManager.state before reboot but, perhaps it was updated after reboot as it was correct.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.