After upgrade my desktop system (asrock z77, intel i5, geforce gtx 650, 16 GB ram) can only boot to a black screen. I mean after the GRUB interface (kernel is 3.8.8-19-generic) and purple screen.

I have attempted pretty much every work around listed that I have been able to locate on the forums and elsewhere, here are a couple of resources (if anyone else is having a similar issue):


How to set NOMODESET and other kernel boot options in grub2

I have modified grub entry several times in different ways. It tends to hang at this point with statement "Loading initial ramdisk ..."

Attempted to reinstall Ubuntu's system files following UbuntuReinstallation guide, but:

(i.) option to upgrade is not available; (ii.) install via manual partitioning (something-else) has issues, when I select the "sda1" partition and click install now I get an error message saying that "No root file system is defined".

**this error message occurs regardless of setting mount point as "/"

I then tried 'boot repair', thinking it might be something that could help: http://paste.ubuntu.com/5627802/

I am at the point that I am thinking the microsoft solution for serious BSOD was to take the box outside and shoot it or toss it off a bridge from a moving vehicle is the only viable option.

If anyone can help, make some suggestions - it would be greatly appreciated.

Thanks in advance.

Footnote: Sunday 10th May 2013

Over the last week, I have attempted multiple times to create a work around to this 'blank screen' issue. To the point I have built a second identical machine, two separate Nvidia graphics cards (GTX650 & GTS450) to play around on with fresh installs of 12.10 and 13.04

I have followed numerous suggestions from forum threads, bug reports and askubuntu posts:

Ubuntu 12.10 / 13.04

sudo apt-add-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings
sudo apt-get install linux-headers-generic
sudo apt-get --reinstall nvidia-current nvidia-settings
sudo reboot

As well as:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings
sudo apt-get install linux-headers-generic
sudo apt-get --reinstall nvidia-current nvidia-settings
sudo reboot

I have done the 'remove':

sudo apt-remove nvidia-current nvidia-common
sudo apt-remove nvidia-current-updates

I have 'reconfigured':

sudo dpkg-reconfigure nvidia-current
sudo dpkg-reconfigure nvidia-current-updates

I have purged the butthead drivers released by nvidia:

sudo apt-get purge nvidia*; sudo rm /etc/x11/xorg.conf

Installed new nvidia drivers (310, 319) following some of the above:

sudo apt-get install-experimental-319
sudo apt-get install-319-updates

Cleared Nouveau (as it was not being blacklisted):

sudo apt-get --purge remove xserver-xorg-video-nouveau
sudo apt-get install linux-headers-'uname -r'
sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings
sudo apt-get-alternatives --config gl_conf
sudo ldconfig
sudo update-initramfs -u
sudo nvidia-xconfig

Redone Unity by installing 'dconf-tools'.

Original and test system both have nvidia graphics cards to which monitors are attached, however neither appear in 'additional drivers'. In the case of the test system, this is regardless of whether the card is in the PCI slot with fresh install or added later in both 12.10 and 13.04.

When I do: 'lsmod | grep -i nv' after install nvidia, the nvida data is there, but the system still boots into blank screen. I have played with 'lightdm' and 'nomodeset'.

In the case of editing grub to add 'nomodeset' in test system, this causes the system to hang after 'Loading initial ramdisk ...'

So, if anyone has some thoughts, I am all ears.

  • Even though you've got a black screen, sometimes you can still login to Ubuntu by pressing the keyboard combination Ctrl + Alt + F2 to bring up a text-only console. You will be prompted to type your username and press Enter. You will be prompted to enter your password. After you have logged in to the console type sudo lightdm. You will be prompted to enter your username and password as before. This will (hopefully) bring up your normal Ubuntu login screen. – karel May 3 '13 at 6:25
  • Thanks for the reply, tried the keyboard combination Ctrl + Alt + F2, it did not work. No text-only console, same old blank black screen after initial Grub interface. I am still persisting with attempting to find a solution, if 'anyone' else can throw up some tips or ideas - it would be greatly appreciated. – BigAnt May 3 '13 at 23:32
  • I am able to boot into 'recovery mode', although when I run dpkg to fix broken packages, I get end result of: mountall: fsck /boot [1344] terminated with status 1 – BigAnt May 4 '13 at 1:15
  • I have been thinking of pulling my graphics card out and attempting to boot using on-board graphics. Unsure if it is going to work, but am wondering 'if' anyone else has had success getting system up and running to fix issue this way? – BigAnt May 4 '13 at 1:20
  • Yes, for example this question. – karel May 4 '13 at 1:35

I had this happen, I had to experiment by loading up previous versions as listed in the grub 2 boot selection screen. then when i found a kernel that loaded I set it as default.

what I had discovered by searching google, was for some reason 13.04 places two unusable kernels in the boot selection. I had 3.8.0-19 and 3.5.0-28 which are non functional kernels. the kernel that is needed was 3.2.0-40. after removing and setting the right kernel in grub to the new default , all was fine and 13.04 works beautifully

  • Hi 'upchucky' - thanks for your tips. I went and installed various kernels, going back quite a ways (3.7.8, 3.8.1, 3.8.3) and eventually installed the latest kernel 3.9.0-030900-generic to get the system up and running. I have had to edit grub2 with 'nomodeset' to get a bootable device - something I can live with as I try and figure out 'how to fix the blank screen the system boots into'. Have uninstalled and replaced nvidia drivers to nvidia 310 to get working, there was a conflict with 304 and the like. Still plodding along to work out a fix, but thanks for your help. Greatly appreciated! – BigAnt May 8 '13 at 0:34
  • 3
    What?? 3.2?? That's ancient. This really doesn't make a lot of sense. – Pointy May 9 '13 at 0:35
  • I did not use 3.2, but I did go back as far as 3.5 and had no success. However, when I updated to the 3.9 kernel I could use 'nomodeset' by replacing 'quiet splash' in grub load menu and my system would boot. – BigAnt May 12 '13 at 5:08

I had the same problem when I installed Ubuntu 13.04 on the Asus g55vw with Nvidia gtx 660M. On my case it booted the live cd and installed Ubuntu without a hitch. The installation completed with a success. Once it rebooted it went straight into the black screen.

My FIx.

  1. I disabled secure boot and fast boot from bios
  2. Boot into GRUB. Hold shift from the time you press the power button until you see Grub.
  3. select advanced boot options
  4. It will give you two options ubuntu.xx and ubuntu recovery. select recovery.
  5. Wait for a screen to appear giving you options. I selected Grub option. It updates the grub to the most recent version.
  6. I rebooted the pc
  7. Go into grub again
  8. repeat steps 2 - 4
  9. Once at the boot options screen again selecte allow networking to enable internet
  10. after that select root shell from that same menu
  11. Once in shell I followed a tutorial in how to install the NVidia drivers published here: dedoimedo.com - Install nvidia drivers tutorial

The drivers were installed fine and the pc rebooted to the desktop perfectly. Hope it helps good luck


Try to plug in antother screen into your computer.

I updated to the new 13.04 and after a reboot everything was fine, but then I removed the extra screen connected to the VGA output.

Shut down and reboot and then the black screen.

Shut down and rebooted several times but every time just a black screen.

Plugged back the extra screen and wala! Both screens are back.

Remove the extra screen and the laptop screen adjust to better resolution and remain on.

Restart without the extra screen and the black screen is back!

All is well as long as two screens get connected.

Don’t think it has anything to do with the driver since it was working well on the Ubuntu 12.


I found the link provided by jorge was the most helpful.

The link is: dedoimedo.com - Install nvidia drivers tutorial

I followed some of the steps. I have listed them below.

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install build-essential linux-kernel-headers

The I used the Additional Drivers GUI to install the nvidia 313 driver. I ran a few more commands to check that the driver was loaded.

See if the module is loaded.

sudo /sbin/lsmod | grep nvidia

Checked that the all kernel module dependencies where satisfied and resolved.

sudo depmod -a

Forced the driver to load.

sudo modprobe nvidia

Created the xorg.conf file.

sudo nvidia-xconfig

Restarted the session manager

sudo /etc/init.d/lightdm restart
  • Please don't add 'thanks' as answers. Invest some time in the site and you will gain sufficient privileges to upvote answers you like, which is the Ask Ubuntu way of saying thank you. – Braiam Sep 19 '13 at 4:17

hi I had similar problem, I fixed it...

  1. boot to recovery mode
  2. enable network
  3. now select dpkg repair option
  4. files get downloaded & packages re-installed
  5. re boot when prompted

Black Screen LightDM SSD Boot Fix

The above link should fix the boot problem.

happy ubuntuing!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.