I get the following message on Ubuntu 12.04 LTS i386 during the boot process:

Disk Drive for dev/mapper/cryptswap 1 is not ready or not present

It will give me the message about 3 times and then finally load but I am also getting internal errors (Last night and this morning I pretty well was flooded with them).

I am completely new to Ubuntu and Linux so am I doing the best I can to learn as quickly I am able but it would really be helpful if I could chat with someone as the machine I have apparently is a bit of a pain in general (HP dc7700sf).


I had the same issue. Eventually it turned out that the device in /etc/crypttab was wrong.

The system was installed from a USB pen-drive, so during installation the pen-drive was /dev/sda and the hard disc was /dev/sdb. The swap partition was hence written into /etc/crypttab as /dev/sdb6. After booting from the harddrive this became /dev/sda6 and the mapper could not find it any more.

To fix this just correct the line in /etc/crypttab to the correct /dev/sd?? or the UUID of the swap partition.

  • 2
    Thanks for this answer - the hint to replace UUID by /dev/sdaX in the /etc/crypttab file actually helped in my case (the Puny Geek post uses UUIDs exclusively, and that for some reason prevented the remedy in my case). Other than that, this is a known bug reported in the Ubuntu bugtracker Apr 12 '14 at 19:58
  • Hello verwaltungspraxis, It is only one time fix. After second reboot the same message will appear and also when it succeeds first time, if I put my system to hibernate, the same message appears and the system state will not be persisted.
    – learner
    Jul 23 '15 at 2:49
  • Why on earth was this done by the installation in the first place?! Aug 15 '15 at 9:18

I was getting the same error message. I tried what is being suggested here but the error persisted. (By the way, instructions given in one of the links there is incomplete. Read comments from others underneath the post and that should take you to the right direction).

I came across this post that solved the problem for me by delaying swapon.

I did the following:

sudo gedit /etc/fstab

I changed the line

/dev/mapper/cryptswap1 none swap sw 0 0

to read

/dev/mapper/cryptswap1 none swap sw,noauto 0 0


sudo gedit /etc/rc.local

and immediately before

exit 0

added these two lines:

sleep 5
swapon /dev/mapper/cryptswap1

Maybe this helps? Seems to be the answer for a few similar problems:

Puny Geek: Ubuntu 12.04 - How to solve "The disk drive for /dev/mapper/cryptswap1 is not ready yet or not present" error at boot


I got same error message when I had NO ENCRYPTED SWAP at all, just normal swap, after an upgrade from 13.10 to 14.04. I checked with Gparted & realized that it wasn't recognizing my former swap partition, so I formatted it as linux-swap, rebooted and it was done.


I could not find convenient solution to this problem.

I run Ubuntu 14.04 and that helped to me:

 sudo mkswap /dev/mapper/ubuntu--vg-swap_1

You can then mount your swap using:

 sudo swapon -a

That's it. After restarting your machine you should've swap mounted, because it should've been already configured in /etc/fstab.

Not the answer you're looking for? Browse other questions tagged or ask your own question.