I've set up pulseaudio on my Ubuntu server to receive tcp streams like suggested in the pulseaudio documentation and many tutorials. My /etc/pulse/default.pa now contains these lines:

load-module module-esound-protocol-tcp auth-anonymous=1
load-module module-native-protocol-tcp
load-module module-zeroconf-publish

I've restarted the daemon using

pulseaudio -k
pulseaudio -D

From my understanding I should now be able to use the server as sink from my client. Ideally I'd like to select the output device with PulseAudio Volume Control but get it to work at all. I've tried to set PULSE_SERVER to point to my server but I get playback errors.

Can anyone tell me if my server configuration is right and how to configure the client (13.04)?


I finally found out that I have to load the module module-zeroconf-discover on the client. If I now restart the daemon on the client the server is discovered but the sink can't be created. /var/log/syslog says this:

pulseaudio[4877]: [pulseaudio] module-tunnel.c: Failed to create sink.
pulseaudio[4877]: [pulseaudio] module.c: Failed to load module "module-tunnel-sink" (argument: "server=[]:4713 sink=auto_null format=s16le channels=2 rate=44100 sink_name=tunnel.myserver.local.auto_null channel_map=front-left,front-right"): initialization failed.
pulseaudio[4877]: [pulseaudio] module-tunnel.c: Failed to authenticate

I don't quite get how it can fail to authenticate if anonymous login is allowed.


The authentication failure seems to happen randomly. If it doesn't appear the relevant log entry is

[pulseaudio] module-tunnel.c: Stream died.

instead. The other two entries look the same.

1 Answer 1


The same here. But in my case pulseaudio discovers a remote source, but not sink. However, there are typical error messages in log for both of them.

Another thing to mention is that fail message about module-tunnel-source is different from the one about module-tunnel-sink.

The second has server address argument written in IPv4 form (192.168.0.x) while the first mentions address in IPv6 form. Don't know why there is that difference, but it remains the whole time and somehow module-tunnel-source with an IPv6 address is loaded, but sink is not.

Maybe it's just a bug and we should think how to file a bug report correctly.


I think I've already found solution:


According to it you should disable IPv6 in avahi-daemon and restart it. It worked for me.

  • Hi, 13.04 is no longer supported at Ask Ubuntu because it has reached end of life.
    – DK Bose
    Feb 28, 2014 at 6:16
  • @DKBose this is still a problem with 14.04 and 14.10.
    – airtonix
    Jun 22, 2014 at 7:20
  • Ubuntu 17.04: I can confirm that disabling ipv6 on the sender's avahi solves the issue.
    – eudoxos
    Aug 31, 2017 at 19:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .