I have a desktop I am dual-booting with Windows/Ubuntu. In Windows, I'm getting around 8-12 mb/s, and in Ubuntu I'm currently getting ~.1 mb/s. I have a Belkin F7D1101 USB Wireless Adapter. I have the latest version of Ubuntu installed.

I'm not really sure what other information would be needed in order to help me, so comment if you need some info on my system.

  • I'm getting around 8-12 mb/s, and in Ubuntu I'm currently getting ~.1 mb/s. I assume you did the test using the same website and just after doing it on Windows, and without having any other software opened. Use speedtest.net or other similar website to see if there's indeed a problem with your internet connection or only with the connection with the specific website you used to do the speed test. – Alex May 2 '13 at 5:32

A little googling found this:


follow those directions exactly and you should be up and running with it.

| improve this answer | |
  • None of those instructions worked for me, I'm assuming because they were intended for Ubuntu 10.10. – Isaiah Bugarin May 2 '13 at 5:42
  • Were you able to get through all of the steps without any problems? They were working for people up to 12.04 and it didn't seem like anyone tried them after that. – Dennis May 2 '13 at 5:55
  • Well, yes, but whenever I do the sudo gedit, it creates a new file with the specified file name, as opposed to opening it. – Isaiah Bugarin May 2 '13 at 11:56
  • Yes, the instructions say the files are likely empty. Just keep following them. – Dennis May 3 '13 at 14:36
  • I followed the instructions all the way through and no luck :( – Isaiah Bugarin May 4 '13 at 1:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.