2

I'm trying the option -follow_mouse with both ffmpeg and avconv and I can't make it work.

avconv version 0.8.6-6:0.8.6-1ubuntu2 tells me:

Option follow_mouse not found.

ffmpeg version git-2013-01-05-6717d1a, doesn't complain, but the outline doesn't follow the mouse, and the resulting video is also not moving.

My full command line is the following:

ffmpeg -f alsa -i pulse -f x11grab -show_region 1 -r 10 -s 960x540 -i :0.0+10,200 \
    -acodec pcm_s16le -qscale 0 -follow_mouse 100 screencast.avi

How to make it work? Am I doing something wrong, or should I get a different version?

1

Option placement matters. -follow_mouse is an input option, but you're attempting to apply it to the output, so ffmpeg will ignore it. Try:

ffmpeg -f alsa -i pulse -f x11grab -show_region 1 -follow_mouse 100 -r 10 \
-s 960x540 -i :0.0+10,200 -acodec pcm_s16le -qscale 0 screencast.avi
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.