I am using Firefox 4.0RC1 from the Mozilla Team's "Firefox Next" PPA.

My about:config has webgl.enabled_for_all_sites set to true as most guides recommend that and also say that is all that is needed. It doesn't work for me.

The main Mozilla Demos page ("Web O' Wonder") gives me:

Unfortunately, while your browser supports WebGL, your video drivers may be too old. To view any of the demos tagged with WebGL, try updating your drivers at NVIDIA, AMD, and Intel.

You can still watch screencasts of the WebGL demos or fully experience our other non-WebGL demos without updating.

My laptop (a Thinkpad x200s) has an Intel GMA 4500HD chipset and my xserver-xorg-video-intel version is 2:2.12.0-1ubuntu5.2

This Mozilla demo gives me "No WebGL context found."

  • 1
    I think the answer to your question is in the details, as it tells you your drivers don't support the features needed for WebGL. Can you tell us what graphics card/chipset + drivers you are using? – RolandiXor Mar 4 '11 at 19:02

Firefox has WebGL enabled for Linux but only the NVIDIA proprietary driver is on the whitelist.

Reference: https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers#On_X11

You could try bypassing that block or use Chromium if you want to see if WebGL is possible on your hardware.

  • Indeed it seems a Firefox-only issue. I have Firefox 4.0 on Ubuntu 10.10 Maverick, kernel: Linux annafi 2.6.35-28-generic-pae #49+kamal~mjgbacklight3-Ubuntu SMP Wed Mar 2 02:55:35 UTC 2011 i686 GNU/Linux, VGA: 00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18), and WebGl doesn't work on Firefox 4.0. However WebGL works on Google Chrome 10 in my Ubuntu. – Hendy Irawan Mar 23 '11 at 11:34

jbicha is spot on. Using the latest proprietary amd drivers for my HD 5550, I opened firefox 4.0 from terminal using: "MOZ_GLX_IGNORE_BLACKLIST=1 firefox"
Voila! Web o' Wonder!

Planetarium had some lag (compared to same card and machine running windows). Everything else ran just as well. Obviously, your results may vary.

FWIW, Google Chrome 10.0.648.151 gave me the same error message as Firefox 4.0 (without the ignore blacklist command). Haven't tried the new Chrome 11.0.696.16 beta.

Mozilla is busy squashing bugs. Much more WebGL to come, I guess.

I'm running Ubuntu 10.10.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.