im having a bit of an issue with my volume keys.

They worked fine, until I recently updated (kernel, etc) and installing Ati latest driver. The update was a standard update:

apt-get update, apt-get upgrade

And the Ati Catalyst drivers installed where:


I made both installs, a reboot after each one.. but didnt tried volume keys.. so i dont really know which one made the Media keys stop working.

BTW, im running Ubuntu 12.04 with standard Unity interface.

A bit of info:

    Bus 004 Device 002: ID 046d:c517 Logitech, Inc. LX710 Cordless Desktop Laser

The keyboard has 2 sets of media keys, Volume Up, Volume Down, Mute. And aside, Next Track, Play/Pause, Next Track. The second set works ok, i can pause, skip, etc...

But the volume and mute keys are not responding. The output of "sudo showkeys" lists the not working keys as Key 115, 114 and 113.

The configuration on System > Keyboard > Shortcuts is configured fine apparently..

Can anyone point me in the right direction ? Please let me know if i can get you guys any more info..

BTW, manual control works fine, i mean with the volume applet i can control volume.


1 Answer 1


Probably the media keys are not controlling the correct device. Open sound preferences and try to enable/disable things. In my case it helped.

Also see: How to switch 'default' sound device controlled by hardware keys in Xubuntu?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .