11

I use Ubuntu-Gnome 13.04 and I can't change system language. I set it to Polish with "language & regions". It was though because there is no option for adding so i installed:

language-pack-pl

language-pack-gnome-pl

then i could pick it in "language & regions" and then reboot. However this didn't solve my problem I also change it with gnome-language-selector and still got english.

Please help, because if the language is other than polish i will have to switch back to windows. I like the gnome3.

9

Obviously the language support tools are still incomplete in Ubuntu GNOME. Desktop Help states the following:

Select your desired language. If your language is not listed click : at the bottom of the list to select from all available regions or languages.

Only after selecting a language there clicking on Done has no effect.

To have the language selection back in the form it is installed in other releases we have to install language-selector-gnome Install language-selector-gnome. After we did so, we will have an additional icon "Language Support" in our System Settings from where we can install any supported language by choosing "Install/Remove Languages":

enter image description here

Drag the interesting language to the top of the list. Select "Apply System Wide" to also have this language at log in, and system wide.

  • This is the solution in general I think so I mark it as the solution. But in my case I had to uninstall all languages I had (language-pack-pl, language-pack-gnome-pl, language-pack-en, language-pack-gnome-en). Then install both en(language-pack-en, language-pack-gnome-en), then reboot and install both pl (language-pack-pl, language-pack-gnome-pl). – xliiv May 8 '13 at 8:58
  • There is no "Apply System-Wide" in Ubuntu GNOME 17.04. I am stuck and consider editing some configs manually. – Alexey Apr 21 '17 at 12:52
  • @Alexey: did you do sudo apt install language-selector-gnome? Only with this application the new Language Support can be selected as shown above. I just tested this on 17.04 Ubuntu GNOME, it is still valid. – Takkat Apr 21 '17 at 18:19
  • Thanks, @Takkat, i have now a new settings panel. However, what is weird is that i somehow switched the system language to French before (i believe, using the ordinary user language panel) but was not able to switch it back to English. I have already switched it back by editing /etc/default/locale. – Alexey Apr 21 '17 at 21:53
6

If I understand the question right, you want to change everything to polish. If that's the case then, add the language first, and Apply system wide.

enter image description here

Do the same for Regional Format

enter image description here

And add the keyboard layout.

enter image description here

enter image description here

Then you will get the language icon which allows you to switch between keyboard layouts.

enter image description here

  • I try this exactly but language will not set into Turkish. – Erkin Alp Güney Jan 19 '16 at 18:51
2

Specify the language at the login prompt after selecting the user. When asked whether to make the selection the new default, select yes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.