since upgrading to Ubuntu 13.04, I get a window asking for a password for my email address. The window appears after logging into the desktop. The window is titled "Zugangsanfrage" (access request) and "Legitimierungsanfrage" (legitimation request), asks for the password of the acount my email address, gives no further information and doesn't let me do anything until I enter a password or cancel the dialog. It has the option to store the password in the key ring, though. I can start new apps using the starter bar, but I cannot use them move windows, or type into other windows. I cannot even make a screenshot.

I have not even the slightest idea which password to give. Does it ask for my web-mail password or for the ubuntu-one password (where my login is the email address) or is it just a phishing app (but how did I get it). I tried entering some random characters and it is happy.

Update: I added a screenshot: screenshot

  • I've just asked in our chatroom and the quick consensus is this was a keyring window. The keyring stores your various identities and passwords in a secure location. If you've set up a password with truly random keys, you might want to reset the current keyring or you won't be able to unlock it in the future. – Oli May 1 '13 at 9:10
  • no the window gives no further information. The full text is: – joho May 1 '13 at 9:18
  • Legitimierungsanfrage: Bitte geben Sie das Password für das Konto "xyz@example.com" ein. Passwort: .... [] Fügen Sie das Passwort zum Schlüsselbund hinzu – joho May 1 '13 at 9:19
  • 2
    it cannot be keyring, as it is asking if I want to store the password in the keyring (this wouldn't make sense, wouldn't it?) – joho May 1 '13 at 9:21
  • I do believe that that is the keyring: the checkbox asks if it can store it in the keyring. Now we can not see WHAT it is that asks this so... question: do you have a mail client installed on your system? Or do you use Ubuntu One? – Rinzwind May 1 '13 at 9:34

The window comes from gcr-prompter and seems to be this bug:


I will try the workaround mentioned there (removing ~/.config/goa-1.0/accounts.conf)


I had the same issue. I tried to use evolution, but deinstalled it. Unfortunaltey, some packages left over. Thus, run the following command to check, if all packages from evolution are deinstalled:

apt --installed list | grep evolution

In my case, the evolution-data-server was still installed. Thus, I had to run:

sudo apt-get remove evolution-data-server 

Hint: do not remove the evolution-data-server-common. This removes the indicator-datetime, which is the clock in the Unity Panel.


It is the gnome-keyring gcr-prompter Window. You can find out using xprop (with a delay of 5 seconds to have enough time to bring the window in front)

sleep 5 && xprop |egrep 'PID|CLASS'

You will see something like

WM_CLASS(STRING) = "gcr-prompter", "Gcr-prompter"

So if you never used the keyring or forgot the password, you can simply delete your keyring folder (with backup):

mv ~/.local/share/keyrings/ ~/.local/share/keyrings.backup
mkdir ~/.local/share/keyrings/

Then Ubuntu will ask to set a new password the next time the Keyring will be used.

see also: How to recover/reset forgotten Gnome Keyring Password?


In my case, this window was appearing for me because I had previously tried (unsuccessfully) to set up an Exchange email account in Evolution.

As I don't use Evolution, this window served no purpose for me. I stopped it from re-appearing on every login by wiping my Evolution settings:

rm -rf ~/.config/evolution 

That seems like a Thunderbird window to me.

To ensure what application is causing that run xprop, click on that window and look for the property _NET_WM_PID that will give you the PID of the culprit process. Search for that process on ps aux or the gnome system monitor to find out.


I have been under KDE with Plasma 5 and was getting this window. I had a home folder with a very long upgrade path (since Ubuntu 10.04). There was an old Folder


Renaming that one helped me with fixing the unnecessary prompt (I am using KDE's KWallet).


In my case I used Gnome online accounts with Google. After removing it, there is no more password request at start.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.