13

I have Ubuntu 12.04. I use Remmina to connect with remote Windows XP. I have configured Remmina for sharing my user folder, but I cannot see the folder in my remote Windows desktop.

Any idea?

  • For your information. rdesktop is able of sharing local folders. rdesktop works better thatn remmina – Juan Jun 16 '13 at 6:44
  • 3
    Try to activate Sound option in remote desktop preferences, it works for me. – user304498 Jul 11 '14 at 7:48
  • 1
    Activating sound to Local also works for Ubuntu 12.04, using stock Remmina from repositories. – MestreLion Feb 1 '18 at 20:19
15

As with Bor's answer, upgrading to the Remmina 1.2 "next" version solved my issue with folder shares not showing up when RDP-ing from Ubuntu 15.10 to Windows Server 2012 R2.

As in the instructions at https://github.com/FreeRDP/Remmina/wiki, simply run:

sudo apt-add-repository ppa:remmina-ppa-team/remmina-next
sudo apt-get update
sudo apt-get install remmina remmina-plugin-rdp libfreerdp-plugins-standard

or in one line by concatenating the commands together with &&.

Then start Remmina =)

remmina
| improve this answer | |
  • 2
    This fix works and is still necessary as of Ubuntu 17.10 (Artful Aardvark), which only ships with Remmina 1.1.2 with a broken shared folder implementation. – Paul d'Aoust Oct 25 '17 at 18:47
9

the following works from debian wheezy to a remote windows 8 pc using remmina 0.9.99.1:

first run remmina from the command line and see if connecting to your remote host gives any certificate errors:

$ remmina

connected to 192.168.0.x:3389
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@           WARNING: CERTIFICATE NAME MISMATCH!           @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
The hostname used for this connection (192.168.0.x) 
does not match the name given in the certificate:
remote-pc-name
A valid certificate for the wrong name should NOT be trusted!

if you see this warning then use whatever value you see reported instead of remote-pc-name in the server textbox in remmina.

then edit your /etc/hosts so that remmina can find the ip address of this server. make sure a line like so exists:

remote-pc-name 192.168.0.x

second, edit your remote desktop preferences in remmina like so:

basic

  • share folder - set to something like /tmp

advanced tab

  • sound: local
  • security: rdp

make sure to click save.

after this, navigate to my computer on the remote windows desktop and click refresh. the shared folder should appear under other devices and drives right next to local disk C:

| improve this answer | |
  • Dear mullhausen. I tried your solution. It does not work in my case. I have UBuNTU 14.04 – Juan Dec 27 '14 at 19:07
4

after upgrading Remmina from PPA (to 1.2 version): https://github.com/FreeRDP/Remmina/wiki folder sharing works with windows 2012 systems.

| improve this answer | |
2

rdesktop is indeed good at sharing folders. But rdesktop can NOT connect to windows 2012 systems.

Remiina does not seem to be able to share folders successfully with windows 2012 systems.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.