I just tried updating to 13.04 from 12.10. When I restarted, it went to Grub even though there's no other OS on the computer. I clicked on Ubuntu to finish booting and I got a terminal with the error message:

General error mounting filesystems.
A maintenance shell will now be started.
CONTROL-D will terminate this shell and reboot the system.

Reboot brings me back to the exact same place.

The only other options on Grub are Advanced options for Ubuntu and a couple of memory test options. I ran one of them and it came out fine.

I have no idea what to do next. Please advise.


Per request, here is the contents of /etc/fstab:

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices 
# that works even if disks are added and removed. See fstab(5).
# <file system>  <mount point>   <type>   <options>        <dump>   <pass>
# /was on /dev/sda1 during installation
UUID=5b22f712-cd92-446e-8984-0c31ca17c02c /                ext4     errors=remount
-ro 0       1
# swap was on /dev/sda5 during installation
UUID=86ea10b7-9309-4860-8ade-059f9d9fa328 none             swap     sw
  0       0
  • Did you create your /home directory on a separate partition. Probably your system couldn't mount the /home directory. So you're unable to log in with the user you created. – user85164 May 1 '13 at 2:12
  • Please share the contents of /etc/fstab – thefourtheye May 1 '13 at 2:50
  • @Frank It's a standard install using the whole disc. No separate partitions. – jimchristie May 1 '13 at 13:31
  • @thefourtheye How do I access the contents of /etc/fstab when I can't boot the computer? – jimchristie May 1 '13 at 13:31
  • I see that you have a shell. I think, you can just do cat /etc/fstab – thefourtheye May 1 '13 at 13:33

May be the upgrade is'nt complete yet. I find same problem and trying this:

  1. Boot on LiveUSB
  2. mount /dev/sda1 /mnt
  3. chroot /mnt
  4. sudo apt-get update
  5. sudo apt-get dist-upgrade
| improve this answer | |

I followed the steps in Sukmono's answer:

  1. Boot on LiveUSB
  2. sudo mount /dev/sda1 /mnt
  3. sudo chroot /mnt
  4. sudo apt-get update
  5. sudo apt-get dist-upgrade

That much got me an error and a suggestion that I run sudo apt-get install -f. I did so and that fixed the problem. After shutting down, removing the LiveUSB, and rebooting, Ubuntu 13.04 booted right up.

| improve this answer | |
  • When I do "sudo chroot /mnt" I get a message that says "chroot: failed to run command '/bin/bash': No such file or directory". Yet I can mount /dev/sda1 to /mnt – Patrick Sep 22 '13 at 15:24
  • I know this is about a year late, but if you're still running in to issues doing sudo chroot /mnt, then try following this to be able to do sudo chroot /mnt: askubuntu.com/questions/270753/… – richsinn Jun 14 '14 at 7:30
  • I had an LVM, which was harder to mount than just mount /dev/sda1 /mnt. I followed the instructions here and successfully mounted it. – Duncan Jones Sep 16 '14 at 12:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.