I recently installed Ubuntu 13.04 and Virtualbox 4.2.10-dfsg-0ubuntu2 with guest extensions installed and my Windows7 guests running in Seamless mode have the bottom part chopped off. The Windows Start button is slightly taller so it peaks out from below and that visible bit is clickable. This did not occur in 12.04.

It seems like the Virtualbox seamless boundaries end too high up (perhaps they start at the top behind the Ubuntu top panel) and the boundaries are not in sync with the Windows guest, or else the Windows Start menu/taskbar would also just appear higher up and not chopped off at the bottom of the screen.

I have tried enabling the 3D Acceleration Mode for the vm but that didn't help.


  • I am running the proprietary Nvidia graphics drivers (nvidia-310 310.44-0ubuntu2)
  • I have disabled the global menu
  • I am using sloppy mouse focus

I will try to put this back to stock Ubuntu 13.04 and see if that fixes the problem.

UPDATE: Restoring global menus did not fix the problem.

UPDATE (2013-05-02): I was resizing the window of a program running in the Windows7 guest and when my mouse cursor hit the bottom of the screen, it seems the entire guest desktop pans down. But this left things less usable so I had to restart the guest vm. I suspect this has something to do with the interaction between Unity's top panel and Virtualbox since the effected parts are the height of the top panel.

closed as off-topic by Seth, Braiam, Eric Carvalho, user117103, Alaa Ali Sep 16 '13 at 17:58

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Seth, Braiam, Eric Carvalho, guntbert, Alaa Ali
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I'm having 100% same issue (host: 13.04, guest: XP 64bit, VirtualBox: 4.2.12). Difference: Intel HD Graphics, so at least we can exclude this being Nvidia-only issue. I didn't have this in 12.10. / Btw, you don't need to restart if things become "unsable" - use the Host key+L (Host key: right Ctrl?) to turn off seamless mode. – pileofrocks May 3 '13 at 9:48
  • I took a quickish look at at Launchpad and VirtualBox's bugtracker, found nothing relevant with the keywords I used. :( – pileofrocks May 3 '13 at 9:57
  • Having the same problem with AMD Graphics so +1 to it not being a graphics driver issue. Worked until upgrade to 13.04 which makes me think its a unity/compiz regression. Edit: Logged in to Gnome-shell (mutter/gnome3) and it works. I'm assuming this is a bug with virtualbox caused by a change in unity/compiz. – user156548 May 7 '13 at 18:52
  • @Josh Also tested with another DE (MATE), and it works. I think a bug should be filed but is there yet enough information? – pileofrocks May 8 '13 at 18:52
  • 1
    I posted bugreport, so if someone wants to raise it's priority, please make me a favor. – Danatela Jul 22 '13 at 8:29

I had essentially the opposite problem, windows host and a Ubuntu 13.03 guest. However the resolution to my problem may be what you need as well- perhaps setting the resolution this way on your Ubuntu host will solve the problem with your windows guest:

Screen Resolution issue on Ubuntu 13.04 installed under Virtualbox

  • Nope. Was that issue even about seamless mode? Everything works correctly in non-seamless mode and it ONLY affects Virtualbox, everything else in host-Ubuntu displays correctly. – pileofrocks May 10 '13 at 21:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.