I have read most of the answers that seem relevant to this, but I thinlk my issue is different and I haven't found the answer.

I have a new HP Pavilion HPE h8-1360t computer. It has Windows 7 and Ubuntu 12.04.2 in a dual boot configuration. It has a Ralink corp. RT5390 Wireless 802.11n wifi controller and an Atheros Communications Inc. AR8161 ethernet controller. I have two Lynksys WRT160N routers connected to different WANs and using DHCP for LAN client conmnections.

In Windows I can connect to the routers via WiFi and via wired ethernet. In Ubuntu, I can connect fine via WiFi, but ethernet connections 'try' for a while and then give 'wired network disconnected'.

It appears I have the required driver and sudo modprobe alx executes without error, but I can never establish a wired ethernet connection.

$ lspci | grep ^0[34]
03:00.0 Network controller: Ralink corp. RT5390 Wireless 802.11n 1T/1R PCIe
04:00.0 Ethernet controller: Atheros Communications Inc. AR8161 Gigabit Ethernet (rev 08)

$ sudo lshw -C network
       description: Wireless interface
       product: RT5390 Wireless 802.11n 1T/1R PCIe
       vendor: Ralink corp.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 00
       serial: 20:10:7a:89:4d:ef
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt2800pci driverversion=3.5.0-27-generic firmware=0.34 ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:f7200000-f720ffff
       description: Ethernet interface
       product: AR8161 Gigabit Ethernet
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: eth0
       version: 08
       serial: 70:54:d2:97:05:11
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=alx driverversion=1.2.3 duplex=full firmware=N/A latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:17 memory:f7100000-f713ffff ioport:d000(size=128)

$ ifconfig
eth0      Link encap:Ethernet  HWaddr 70:54:d2:97:05:11  
          inet6 addr: fe80::7254:d2ff:fe97:511/64 Scope:Link
          RX packets:306 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1617 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:174710 (174.7 KB)  TX bytes:335752 (335.7 KB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1401 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1401 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:112404 (112.4 KB)  TX bytes:112404 (112.4 KB)

wlan0     Link encap:Ethernet  HWaddr 20:10:7a:89:4d:ef  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::2210:7aff:fe89:4def/64 Scope:Link
          RX packets:7621 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6083 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3181961 (3.1 MB)  TX bytes:911510 (911.5 KB)

It seems that eth0 is up and that there is some communication, but I still get the 'wired network disconnected' alerts every minute or so and don't ever get connected.

Also it seems that if this were some DHCP protocol issue, the WiFi connection to the same router wouldn't work either.

I am lost. Can anyone help?

  • Have you tried disabling the IPv6 protocol on eth0? It seems that is the only connection that is active on Ethernet and there is no IPv4 address listed.
    – douggro
    Apr 30, 2013 at 20:55
  • I tried disabling the IPv6 protocol on eth0. It makes no difference. I think the reason there is no ipv4 address is that this is obtained via DHCP from the router and that's what's not working. You can see from ifconfig that packets are being exchanged, but a connection never gets established Apr 30, 2013 at 23:58
  • I just want to be clear: are you connecting to the same router with both connections (wifi and Ethernet), or a different router with each connection?
    – douggro
    May 1, 2013 at 4:50
  • Say the wired connection is R1 and the other is R2. I can connect to both R1 and R2 via WiFi although not simultaneously of course. May 2, 2013 at 4:13
  • You have R1 and R2; you connect to R1 via wifi - do you then try connecting to R1 via Ethernet, or to R2 via Ethernet? And if it is to R2 via Ethernet, is R2 operating with a different DHCP address range than R1?
    – douggro
    May 3, 2013 at 7:04

3 Answers 3


In network-manager on tab Ethernet set MTU size to 8192. https://bugzilla.kernel.org/show_bug.cgi?id=70761

  • I have the same network card and the same issue. This worked like a charm (despite that it is quite a hack)!
    – Xin
    Aug 29, 2016 at 7:39

After running into another post with the same issue and some Google searching, the AR8161 cards seem to have driver support issues under most flavors of UNIX which result in the card showing up in ifconfig but not properly functioning. Answers in this post and this post detail how to install the kernel support needed for the Atheros card.

  • I had actually seen the second of those posts before and tried some of those suggestions with no change. Based on answer 1 in the first post, I now tried installing linux-backports-modules-cw-3.6-3.5.0-27-generic and rebooting, but thast didn't help either. None of this is surprising, as I already had in my system /lib/modules/3.5.0-27-generic/kernel/ubuntu/alx/alx.ko and /lib/modules/3.5.0-28-generic/kernel/ubuntu/alx/alx.ko. I tried running a packet capture ... May 11, 2013 at 20:03
  • on the ethernet port and I find I am sending periodic DHCP Discover requests that look good to me, but I'm not seeing any DHCP Offer response. I don't know if the router is not answering (seems unlikely) or if the packets from the router are being lost. May 11, 2013 at 20:13
  • I'd still bet that it's a driver issue. I'd keep searching here and on the Web for info regarding the Atheros driver until the hardware gets current support in the kernel.
    – douggro
    May 12, 2013 at 5:39

I thought I had reported this a couple of weeks ago as an answer to this question, but I don't see it here. Anyway, a couple of weeks ago, I upgraded to Ubuntu 12.10 and installed the latest updates, and the ethernet interface started working.

Thus, it appears that this is a driver issue and the latest drivers in 12.10 (and now 13.04) do work. I don't know about 12.04.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .