0

I'm trying to start libre office writer up, but it doesn't do anything. I started it from the terminal as root and it showed me this:

ls: error initializing month strings /usr/bin/libreoffice: 49: cd: can't cd to lrwxrwxrwx 1 root root 34 �../lib/libreoffice/program /usr/bin/libreoffice: 156: exec: /usr/bin/oosplash: not found

Is there a known workaround for this, becouse my good friend google couldn't help, and i also couldn't find an answer on this forum.

Ty guys

0

Ugly hack: as root edit the starter script eg: nano /usr/bin/libreoffice

Search for section marked with "# resolve installation directory". There you find a line with an ls command, add the "--time-style=iso " option for ls. The fixed line should look like:

sd_res=ls --time-style=iso -l "$sd_basename" | sed "s/.*$sd_basename -> //g"

You may have to fix more than this invocation of ls. This is a temporary fix, as a new version of libreoffice will overwrite the statup script, so you have to do again if the problem still will be there. Also you can check, if you type "ls -l" into a terminal and no error message then the problem is solved.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.