15

I just installed Rabbitvcs on ubuntu 13.04 as per the official instructions. When i tried to install apt-get install rabbitvcs-nautilus3, i got the following error message :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package rabbitvcs-nautilus3 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
rabbitvcs-nautilus

E: Package 'rabbitvcs-nautilus3' has no installation candidate

So i installed it with apt-get install rabbitvcs-nautilus, and now rabbitvcs options are not showing when i right click on a folder. Any help and suggestions will be highly appreciable. Thanks.

12

I added the below symlinks

sudo ln -sf /usr/lib/i386-linux-gnu/libpython2.7.so.1 /usr/lib/libpython2.7.so.1

sudo ln -sf /usr/lib/libpython2.7.so.1 /usr/lib/libpython2.7.so.1.0

and replaced the /usr/share/nautilus-python/extensions/RabbitVCS.py with RabbitVCS.py

Now its working fine for me. :)

9
$ sudo ln -sf /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0 /usr/lib/
$ sudo ln -sf /usr/lib/x86_64-linux-gnu/libpython2.7.so.1 /usr/lib/

plus downloading RabbitVCS.py's new version helped on my x64 installation. This file need to be copied to /usr/share/nautilus-python/extensions/RabbitVCS.py using root/su/sudo

4

I had the same problem but not from a fresh install, from an upgrade from 12.10.

The nautilus graphical interface of RabbitVCS is not working.

I raised a ticket with the RabbitVCS developers. You can monitor it here, in case a solution is found:

https://code.google.com/p/rabbitvcs/issues/detail?id=803&q=13.03&colspec=Stars%20ID%20Type%20Status%20Priority%20Milestone%20Owner%20Summary

Thanks,

Yannis

  • Hi Yannis, Thank you for the answer. I will monitor the ticket you provided. For the time being could you please guide me to how to checkout via command line. – LX7 Apr 30 '13 at 10:41
  • 1
    just write svn checkout <URL> <local dir path where you want to checkout> (. represents current dir) and it will work... see svn --help – Amit May 3 '13 at 10:15
3

I know this has been answered already, but here are my steps in order to fix the problem on Xubuntu 13.04:

Firstly, I replaced /usr/share/nautilus-python/extensions/RabbitVCS.py with RabbitVCS.py.

Then in the terminal run:

sudo ln -s /usr/lib/x86_64-linux-gnu/libpython2.7.so /usr/lib/libpython.2.7.so
sudo ln -s /usr/lib/x86_64-linux-gnu/libpython2.7.so.1 /usr/lib/libpython.2.7.so.1
sudo ldconfig
killall nautilus
nautilus

If this doesn't work for you, then you can find out which libraries RabbitVCS could not find by running:

nautilus --no-desktop -q

Related (and potentially useful):

  • nautilus --no-desktop -q helped a lot. Thanks – Mircea Nistor Nov 1 '13 at 11:29
2

Just restart nautilus. Sometimes it's working in background to show the desktop icons (this is my case).

Solution:

sudo killall nautilus

Enjoy!

  • always try this before the accepted answer. worked like a charm for me in 12.04, nautilus3 – infoclogged Nov 15 '16 at 11:34
0

In my Ubuntu 13.04 raring x86 - I solved

sudo ln -sf /usr/lib/i386-linux-gnu/libpython2.7.so.1.0 /usr/lib/libpython2.7.so.1.0
sudo ln -sf /usr/lib/i386-linux-gnu/libpython2.7.so.1 /usr/lib/libpython2.7.so.1
killall nautilus
0

On Ubuntu 13.10, the above suggestions have been helpful. Although it seems like sometimes they work and sometimes don't for me. Many times I still don't get the right-click context menu to show SVN/Git stuff. Then after doing...

nautilus --no-desktop -q

I noticed that there was a permission issue with /home/[me]/.config/rabbitvcs - and it turns out it was owned by root (probably because I used sudo while doing something to install rabbitvcs), so when I changed it to be me again, I got my context menu working after a nautilus restart

Just thought this might help someone

0

If you do not have libpython2.7.so.1.0 into /usr/lib/i386-linux-gnu then you can install it by using sudo apt-get python2.7. After installing just reboot your system or restart your nautilus.If this still not solve your problem then install rabbitvcs-thunar into your system.

-1

The problem was related to the permissions for me also. When (on my Ubuntu 12.04 32b) I added a new user, the rabbitvcs stopped to work on the first user. I solved the problem deleting the .config/rabbitcsv directory and restarting the nautilus.

  • The question is about installing Rabbitvcs, not about running it. – Florian Diesch Jan 26 '14 at 16:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.