10

I have a Dell Inspiron 5520 with intel core i7 and AMD Graphics card. It used to work fine with Ubuntu 12.04 and Ubuntu 12.10. Now I tried to install Ubuntu 13.04 but i can't change display brightness: the FN keys don't change it, the indicator shows it always almost full, but won't change, won't increase or decrease. The same problem is there for both x86 and amd64 versions of Ubuntu.

What's the problem?

10 Answers 10

10

I had the same problem, and solved after put this line:

GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

in /etc/default/grub file, and after:

# update-grub && reboot

I have one Dell Vostro 3560 running Ubuntu 13.04 x86_64 kernel 3.8.0-19-generic

And I'm using generic X.Org video driver (opensource, tested)

  • Thanks, this doesn't work with Nvidia but I went back to the X.org driver and brightness controls work now! – Elijah Lynn Jul 17 '13 at 1:58
  • This bricked my Dell Inspiron 17 3721. Won't boot even in recovery mode. – randomfactor Nov 13 '15 at 16:11
7

The following fixed the problem in my Acer laptop.

Open etc/default/grub with a root text editor

sudo -H gedit /etc/default/grub

Change

GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

to

GRUB_CMDLINE_LINUX="quiet splash acpi_osi=Linux acpi_backlight=vendor"

After this run sudo update-grub and restart the system.

  • Sadly, that doesn't work on my Acer laptop with Ubuntu 14.04! It lets me toggle brightness change, but the brightness doesn't change... any ideas? shall I start a question specifically for this? – Alexandre Holden Daly May 6 '14 at 1:24
  • That worked for me, thanks. But it would be helpful if you could explain what these commands do? – Ahmed Dhanani Sep 25 '17 at 12:55
5

Find video/graphics card in Ubuntu and Linux Mint

Run the command below in terminal to know what video card is used for the backlight/brightness:

ls /sys/class/backlight/

find graphics driver in Ubuntu

As you can see, the output for me is dell_backlight and intel_backlight. An indicator that the graphics card in use is Intel. Another way to find out the graphics card would be to go in System Settings->Details->Graphics. You can see the graphic card in use.

If your graphics card is Intel, you can proceed with the fix below. Fix brightness control issue with Intel card in Ubuntu and Linux Mint:

Open a terminal and create the following configuration file, if it does not exist:

sudo touch /usr/share/X11/xorg.conf.d/20-intel.conf

Now we need to edit this file. You can use any editor be it a terminal one or graphical.

sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf

Add the following lines to this file:

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"

EndSection

Save it. Log out and log in back. The brightness control should be working through function keys now:

Fix brightness control not working in Ubuntu 13.10

4

i have the same issue in lenovo G580,

but I resolved it by editing grub,

/etc/default/grub file

and put this line in the end

GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

and after that update the grub,

 update-grub

and done

1

I got the same issue on Asus Zenbook UX32VD but I've solved by adding a comment mark # before the following line in /etc/default/grub file:

GRUB_CMDLINE_LINUX="acpi_backlight=vendor"
1

GRUB_CMDLINE_LINUX_DEFAULT="splash quiet acpi_osi='!Windows 2012'"

this works out best with most laptops having this issue including my ASUS K55VM. Its from Ubuntu Zenbook prime wiki https://help.ubuntu.com/community/AsusZenbookPrime

1

I have an Asus laptop and this is what I did to fix the brightness issue. Instead of using the fn + brightness up/down keys, try using fn + alt + brightness up/down. Hopefully that helps.

1

None of the options here worked for me with an Asus Zenbook UX303. I ended up creating custom shortcuts and using the xbacklight package.

sudo apt-get install xbacklight
xbacklight -set 50 # set to 50%
xbacklight -inc 5 # increase by 5%pt
xbacklight -dec 5 # decrease by 5%pt

Then you can create shortcuts for the -inc and -dec variant. The only thing you miss is the display in the top right saying how bright the display currently is.

0

I assume you installed the amd driver already (dash -> software sources -> last tab)

ubuntuforums.org/showthread.php?t=2139397
look at the kernel boot parameters
the file to edit is /etc/default/grub
after editing run sudo update-grub and reboot

0

Same issue on Acer Aspire E1-531. Resolved with:

Open etc/default/grub with a root text editor:

sudo -H gedit /etc/default/grub

Add:

GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

to end of the file.

After this run sudo update-grub and restart the system.

PS. You can also find GRUB_CMDLINE_LINUX="" on line 12. Just add acpi_backlight=vendor.

Run update-grub and restart the system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.