It will work for a while and then randomly disconnect. Its quite annoying, especially when streaming any sort of media. I have tried it on multiple networks and it happens regardless of network. At home, I have 3 bars on the wi-fi indicator.

I am aware you probably need more information. Please tell me what you need so and how to find it. I don't have any programming skills, and bought the laptop on the hope that "Linux for Humans" was real. Now I find myself going back to my old mac just to avoid the problem.

02:00.0 Network controller [0280]: Atheros Communications Inc. AR9462 Wireless Network Adapter [168c:0034]

2 Answers 2


I have the same laptop!

I bought it from amazon, here, and according to the reviews there, lots of people had problems with wireless. This laptop ships with Ubuntu 12.04, and this problem is fixed by updating to the latest version of Ubuntu, 13.04.

To do this,

  • hit the super (windows) key, then type "update," then click on "Software & Updates"
  • select the "updates" tab
  • at the bottom, next to "Notify me of a new Ubuntu version", select "For any new version" (you'll have to type in your password)
  • close the window, hit the super key, and launch "Software Updater"
  • From here, you should be given the option to upgrade Ubuntu from 12.04 to 12.10
  • After this is finished (should take a couple hours), you'll have to repeat the process to upgrade from 12.10 to 13.04

After you update Ubuntu, there are a couple other bugs that pop up, or at least they did for me: suspend stopped working, and sometimes newly opened apps would open behind the current window. To fix these problems, you can check here and here.

Good luck!

  • 1
    This is great! Could you perhaps add some screenshots too?
    – Seth
    Jun 29, 2013 at 15:45
  • Totally worked. Who would have guessed it would be as simple as updating my system? I've been streaming grooveshark while visiting facebook, checking email, and reading articles on cracked for the past few hours. Hasn't disconnected yet! Thank you!
    – Andon
    Jul 10, 2013 at 4:42

I have the same problem ... not just on Ubuntu, but on Lubuntu 13.04, Windows 7 and Linux Mint 14 as well.

Setting the router to use "G only" (instead of g, n and/or b) seems to help, but it's a rather poor solution.

The network card in question is: Atheros 9485.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .