Did new install of Ubuntu 13.04 on a 64-bit system. HP Laserjet P1006 printer is not recognized. Printer was working fine on Ubuntu 12.10. Searched for HPLIP on the hp.com website. Ubuntu 12.10 is the highest OS release listed on the hp driver site. Ubuntu software center indicates that HPLIP 3.13.3-1 is already installed. Did an uninstall/reinstall -- same problem. How to get this printer working in U13.04?

Update 5/1/13 -- The repository for HPLIP (HP Linux Imaging and Printing) is found at http://hplipopensource.com/hplip-web/index.html . Highest Ubuntu release listed at that site is 12.10. Ubuntu 13.04 may be too new for HPLIP compatibility to be worked out. I have dropped back down to Ubuntu 12.04, and will monitor the hplipopensource.com site for a version of HPLIP that is compatible with U 13.04. --gs

  • I'm running 13.04 and hplip 3.13.3-1 straight from the software center with no problems. – Marc Jun 15 '13 at 16:05

I have the same printer and had the same problem.

What I did to solve it:

  • Downloaded HP LIP 3.13.5 from here
  • Note: if you don't have python-dev you should install it
  • Installed HP LIP with default options, except one about re-plug or reboot: re-plug didn't work for me for first time, so I've chosen reboot (if you want to save your time - choose reboot)
  • After reboot it appeared that some HP Device proprietary plug-in is missing, so I installed it

Now my printer is working again : )

P.S. If your printer became unresponsive, button "Install Required Plugin" in HP Device Manager->Actions may help you.

  • Worked. Had to do the reboot too. What a terrible situation. – mlissner Jul 29 '13 at 22:40

I have a HP Photosmart Plus which is connected to a Netgear DGND3700v2 router. There was no trouble recognising this with 12.04 but with 13.04 the HPLIP toolbox will not recognise it with the default settings. The advanced settings need to be enabled and SLP chosen instead of mDNS/Bonjour - then there is no problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.