0

PostgreSQL 9.2 is not included standard with 12.10, but my work requires features unavailable in past versions. I had previously followed these instructions to install PostgreSQL 9.2 and there were no problems directly with this install.

I'm now trying to upgrade to 13.04 from 12.10, but encounter an "unresolvable problem" while setting new software channels.

I run update-manager. Everything is up to date, but get the message that 13.04 is available now and I click upgrade. I don't think it's relevant, but before I encounter the major error, I'm told

Some third party entries in your sources.list were disabled. You can re-enable them after the upgrade with the 'software-properties' tool or your package manager.

This does not impede the install, so I close it and continue. Fetching completes and it begins setting new software channels. I then encounter the "unresolvable problem":

Could not calculate the upgrade error message

What do I need to do to proceed with my upgrade to 13.04?

UPDATE:
I uninstalled PostgreSQL 9.2, upgraded, and added PostgreSQL 9.2 (from an older distro package) as described here. This is working fine, I'm running 13.04 and have PostgreSQL 9.2, but this workaround is not possible for our production server. Uninstalling PostgreSQL on the server risks losing our database. I need a solution that does not require removing PostgreSQL, see this question.

5
  • what about removing the package and installing it after upgrade? You can force/downgrade packages but I know how to do it with Synaptic! Apr 30, 2013 at 10:23
  • I did remove postgresql and then installed it again. Will downgrading to 9.1 prevent this error (since 9.1 is in the Ubuntu repos)? What about not losing the database?
    – Matt
    Apr 30, 2013 at 10:49
  • just do your data backup via PGAdmin and you can happily purge the package! Apr 30, 2013 at 12:02
  • I need to do this on a server, so I can't use pgAdmin, but I can and do backup our data. But it would be best if I could avoid having to remove our database from production and reimport it.
    – Matt
    Apr 30, 2013 at 12:04
  • sudo apt-get remove is not supposed to remove config things just application and its libraries but you cannot trust it. data must be backed up in case of anything. Apr 30, 2013 at 12:15

1 Answer 1

1

Execute the following command to resolve this problem

echo "postgresql-9.2 install" | sudo dpkg --set-selections

1
  • I executed your command and re-attempted to upgrade. I still got the same error. When I executed the command, nothing was echo'd, so I think I might have gone wrong there.
    – Matt
    Apr 29, 2013 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.