0

After upgrading my Acer Aspire 4810T to Ubuntu to 13.04 32bit connection to any wi-fi (or Ethernet) usually fails. Sometimes, maybe once in five tries, rebooting may resolve the problem. Contrary to some other related posts, the proximity of the wifi station doesn't seem to have an impact on the problem.

The wi-fi application indicator in the notification area at top bar of the screen keeps on entering and exiting and the whole system gets very slow. When I click any application indicator their menus often appear empty. Running any program usually quickly freezes the whole system which makes searching the culprit from logs very challenging.

My network card is: Intel WiFi Link 5100 AGN.

The same laptop worked fine with previous Ubuntu version and at the moment it works fine with Windows Vista. With Virtualbox and Windows Vista as a host and 13.04 as a guest it works ok, though slowly.

dmesg shows a long list of network-manager kills and respawns

[ 33.224314] init: network-manager main process (862) killed by ABRT signal [ 33.224361] init: network-manager main process ended, respawning [ 33.709347] init: network-manager main process (1307) killed by ABRT signal [ 33.709393] init: network-manager main process ended, respawning

apport-unpack shows that the NetworkManager has Crashed (ProcCmdline and ProblemType)

apport-unpack also shows warnings in WiFiSyslog

/sys/devices/virtual/net/lo: couldn't determine device driver;

ignoring.. Trying to remove a non-existant call id.

and hints for a firmware bug

May 1 15:31:49 sauli-Aspire-4810T kernel: [ 614.465977] atl1c 0000:01:00.0: vpd r/w failed. This is likely a firmware bug on this device. Contact the card vendor for a firmware update.

Any suggestions, where to start looking for the real problem and how to correct it?

  • Radu, thanks for your proposal. But I don't have bcwl-kernel-source installed. Should I? If yes why? My WiFi card is from Intel. – Sauli Apr 30 '13 at 12:14
  • Anyone else, other proposals? – Sauli May 22 '13 at 6:27
1

Try to use these commands in a Terminal (Ctrl+Alt+T):

sudo apt-get remove bcmwl-kernel-source
sudo apt-get install bcmwl-kernel-source

Or use purge instead of remove to wipe it, then re-install.

  • Does bcmwl-kernel-source work on Intel WiFi Link 5100 AGN? Is Intel WiFi Link 5100 AGN based on Broadcom's BCM4311-, BCM4312-, BCM4321-, and BCM4322? – Tim May 4 '15 at 17:14
1

After reading about the similar problems and trying several of the proposed small and easy fixes, firmware update and network manager reinstallation I gave up. Nothing helped.

Finally I made a full new 13.04 installation. This time with a 64bit version. Now wifi and network manager seem to work fine.

-1

remove network manager and reinstall it using a debian file which you can easily download. and everything will work well. it worked for me on 32 bit.

  • Please explain why this should help. – guntbert Nov 5 '13 at 17:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.