Hardware: HP proliant microserver N40L
OS: Ubuntu server 12.04 (lsb_release gives Ubuntu 12.04.2 LTS, to be precise)
Graphics card: XFX radeon HD 6450 (http://www.ebuyer.com/272721-xfx-hd-6450-1gb-ddr3-dvi-hdmi-low-profile-graphics-card-hd-645x-znh2)

So this microserver has been running ubuntu fine for about six months. However, I recently bought the graphics card above with the intention of running xbmc via an HDMI cable to the TV.

The card appears to work in the sense that the splash/post screens appear fine on the TV, and I can log in on there.

lshw -c video


description: VGA compatible controller
product: Caicos [Radeon HD 6450]
vendor: Hynix Semiconductor (Hyundai Electronics)
physical id: 0
bus info: pci@0000:01:00.0
version: 00
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
configuration: driver=fglrx_pci latency=0
resources: irq:18 memory:d0000000-dfffffff memory:fe8e0000-fe8fffff ioport:e000(size=256) memory:fe8c0000-fe8dffff

This implies the card is detected appropriately. However, I can't run anything graphical on there, and xbmc refuses to start.

In terms of drivers, I've tried following the instructions here What is the correct way to install proprietary ATI Catalyst Video Drivers (fglrx) directly from AMD? and have tried:
-Using the default 'radeon' driver (i.e. without changing any repositories or installing any additional drivers)
- Using the fglrx driver in the repositories
- Using the fglrx-experimental-9 driver
- Adding the xorg-edgers ppa and installing that way
- Directly downloadingd drivers from amd; have tried versions 13.1, 12.4, and 11.12 (obviously not accepting the fglrx upgrades on the last version)

None work.




both give

Error: unable to open display (null)


sudo lspci | grep VGA


01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Caicos [Radeon HD 6450]

I can't actually figure out what's going on, chiefly because while there are suggestions from other HP products that installing >4GB of RAM means certain cards, won't work (e.g. http://h30499.www3.hp.com/t5/ProLiant-Servers-ML-DL-SL/ML150-G5-possible-BIOS-bug-with-add-on-pcie-video-card/td-p/4242397#.UIgFd8VUzWk ), plenty of people seem to be using this card, this OS, and this box without problems.

Looking through here, this question Unity interface issues with AMD Radeon 6450 suggests other people have had trouble with this card on Ubuntu, but it seemed to be fixed by installing a proprietary driver (which I've tried).

This question Does HD 6450 graphics card work fine on Ubuntu? suggests problems with HDMI, but I have also tried using the DVI output with an adapter (as the TV only has a VGA input) without success.

My next steps are probably: (1) Try taking the RAM down to 4GB and see if that works given the problems with other HP boxes above (2) Try running Ubuntu desktop from the liveCD/USB and see if it can pick up the drivers

However, any other help would be really gratefully received, and obviously happy to post any other info if that would help solve the problem. Thanks!

  • 1
    Update: I have now tried changing the bios, which allows me to set the (shared) vga memory size to various things. None made a difference, and nor did changing the "active power state" setting. Will try removing RAM / running from a livecd later and update - any thoughts gratefully received! – nmg20 May 1 '13 at 20:07

I had the same problem as you, The open source drivers were simply not working and I always got this 'Unable to open display error on glxinfo. After two years of using the card I was finally able to solve this by adding radeon.dpm=1 in my linux boot parameters.And now it's working fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.