1

I just noticed my laptop stared working considerably slower. I am using an updated 13.04, though the issue did not start right after the upgrade. After tracking down the issue I noticed that both processors operate at 800 MHz instead of the maximum 1800 MHz. Irrespective of the load, the frequency remains 800. Here are some stats:

$ cpufreq-info 
cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  driver: powernow-k8
  CPUs which run at the same hardware frequency: 0 1
  CPUs which need to have their frequency coordinated by software: 0 1
  maximum transition latency: 109 us.
  hardware limits: 800 MHz - 1.80 GHz
  available frequency steps: 1.80 GHz, 1.60 GHz, 800 MHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance
  current policy: frequency should be within 800 MHz and 800 MHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 800 MHz.
  cpufreq stats: 1.80 GHz:0.00%, 1.60 GHz:0.00%, 800 MHz:100.00%
analyzing CPU 1:
  driver: powernow-k8
  CPUs which run at the same hardware frequency: 0 1
  CPUs which need to have their frequency coordinated by software: 0 1
  maximum transition latency: 109 us.
  hardware limits: 800 MHz - 1.80 GHz
  available frequency steps: 1.80 GHz, 1.60 GHz, 800 MHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance
  current policy: frequency should be within 800 MHz and 800 MHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 800 MHz.
  cpufreq stats: 1.80 GHz:0.00%, 1.60 GHz:0.00%, 800 MHz:100.00%

Note the "current policy" says the frequency is between 800 and 800 irrespective of the hardware limits. The original governor was "ondemand", so I changed it to "performance" in order to see if that makes a difference which it didn't. No amount of invoking cpufreq-set or cpufreq-selector changes the frequency.

Looking around, I noticed several people reported similar issues in the past though no favorable answer exists. Any help would be greatly appreciated.

  • Are you using a power management tool. I started using Granola a while ago. It can boost the maximum CPU frequency. – don.joey Apr 29 '13 at 6:19
  • I am using the standard power management tools & settings that come with (L)Ubuntu. – thenasko Apr 29 '13 at 6:42
  • Try granola on highest performance and see whether your cpufreq-info is the same. – don.joey Apr 29 '13 at 9:59
  • It turns out this may be a issue occurring when running on battery. I started a bug on launchpad -- bugs.launchpad.net/ubuntu/+source/linux/+bug/1174169. – thenasko May 9 '13 at 17:09
2

First make sure that you are connecting to a quality AC source. I had my machine plugged into a long extension cord, and that was part of the problem.

Next, assuming the Bios is getting in the way, try this:

Edit /etc/default/grub

Add processor.ignore_ppc=1 to the GRUB_CMDLINE_LINUX_DEFAULT line.

run sudo update-grub

reboot the computer.

This is from http://www.woolie.co.uk/article/dell-laptop-stuck-800mhz-linux-fix/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.