Every time I use the Dash Home it causes my computer to freeze up and become useless, until I restart it. This issue has plagued me since day 1 of using Ubuntu.

Also, when I first started using Ubuntu a few months ago I was using 12.10, then yesterday I went ahead and upgraded to using 13.04. But this didn't help at all, and the problem persists.

  • Notice that 13.04 has reached End of Life, it's recommend you upgrade to 13.10 or install 12.04 LTS. Consider updating the question to include information about your hardware (PC model, graphics card). If you keep having problems with Unity (Ubuntu's default DE), you could try Xubuntu, Kubuntu, Lubuntu or Ubuntu GNOME. – edwin Mar 24 '14 at 0:50

Try pressing ALT-F2, and typing in sudo apt-get install unity-tweak-tool. Poke around in the settings of the Unity Tweak Tool, under search, and disable background blur. Otherwise, I suspect you have a graphics driver problem. Open System Settings, and go to Software & Updates. Look in additional drivers, see if there's anything listed. If there are proprietary drivers, install them, because they may fix your computer.

You could alternatively install lubuntu, xubuntu or maybe Ubuntu GNOME, and see if they're broken, also.


OK, first want to thank the guys above for suggestions. None of these worked for me unfortunately.

I am using Ubuntu 13.10 and spent lots of time searching for solution online, again, no success.

Then I tried this:

  1. Open System Settings (the gear icon)

  2. Under System, open Software & Updates

  3. Under Software & Updates, select Additional Drivers tab In there I was using open source "X.Org X Server - Noeveau display driver". I looked for one that says "proprietary,tested" and selected that one (in my case, it is "NVIDIA binary Xorg driver, kernel module and VDPAU library from nvidia-319 (proprietary,tested).

  4. Click Apply Changes button and once done, reboot.

Now I'm able to click on Unity Dash icon without it freezing my laptop and leaving me no choice but to hard reboot it.

Hope this helps to other people, too. Thanks.

  • 4 years later, Ubuntu 16.04.3 LTS, same problem, same solution. – tzachs Feb 7 '18 at 20:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.