I have installed Ubuntu 13.04 in a new partition and I have some issues with bluetooth.

I usually use bluetooth to connect to my wireless headset, in the old partition with Ubuntu 12.10 everything is okay.

Ubuntu is able to detect my bluetooth receivers but I can't pair my device. After googling I found that all I need is to add Enable=Socket in the general section of /etc/bluetooth/audio.conf.

After restarting the bluetooth daemon I am able to pair my wireless A2DP receiver and I see the bluetooth adapter under the audio setting, that means that pulseaudio has recognized my A2DP adapter.

Unfortunately when I play the audio file, I hear the output through the PC speakers rather that my bluetooth handcuffs.

Any idea how to resolve this?

I tried formatting and reinstalling Ubuntu 64-bit from scratch in order to get a clean install but the problem is still there. I suspect the Ubuntu team has changed something in the bluetooth settings from 12.10 to 13.04.

  • Did you choose your Bluetooth audio in Sound Settings - Output tab before you started an audio stream? – Takkat Apr 28 '13 at 14:34
  • yes i did, actually my problem is that clicking on the bluetooth output tab nothing happens, i would expect to hear the music played through my wireless receiver but it keeps been playing through my internal speakers – user153241 Apr 28 '13 at 18:47
  • You can't switch a playing sound. You need to stop your player, then switch output, then start player again. Does that help? – Takkat Apr 28 '13 at 19:30

This worked for me:

1) Open /etc/bluetooth/audio.conf with the following command*:

gksudo gedit /etc/bluetooth/audio.conf

(*) The command line above requires gedit and gksu packages.

2) find "Enable =..." under [General] section and delete Socket from the list.

Enable = ....

3) Add this line in General section:

Disable = Socket

4) Save, and close gedit

5) Restart the bluetooth service with the following command:

sudo service bluetooth restart

6) Restart pulseaudio for good measure.

pulseaudio -k 
pulseaudio -D

7) Cross Your Fingers and try.

| improve this answer | |
  • 1
    Editing this file helped me. I did not see Enable=... under [General], but added the Disable=Socket option. I also uncommented AutoConnect=True. That enabled both modes in pulseaudio, allowing me to change from HSP/HFP to A2DP and sound comes stereo. – cuichi Sep 15 '13 at 18:53
  • Similar problem in 16.04: askubuntu.com/questions/775523/… – Rmano May 24 '16 at 19:31

I had almost exactly the same problem as original post. I tried about every suggestion I could find. After days of trial and error my Bose AE2w finally connects and stays connected in A2DP profile.

First, I mute my sound card in sound options before I connect to my bluetooth heaset (this step may be unnecessary, but it is what I do). And I have edited /etc/bluetooth/audio.config with these settings (comments deleted in example)

AutoConnect=false #test later with true

Then click connect in bluetooth options (if it isn't automatic). Last, select the A2DP profile in Sound options. I honestly don't know what some of the setting do, but it has been working for me for 2 days.

I don't know for sure, but I think the root of the problem is that the "Sound" window only lists 1 device (but the device 2 profiles). Because on windows 7/8 in the sound options it lists 2 devices (one for each profile), making it possible to select a "default device [profile]".

Thanks guys, I wouldn't have solved this problem on my own, I hope this helps someone.

edit: this has been working for a week on trusty tahr amd x64 with creative x-fi platinum, bose ae2w, soundbot bluetooth adapter.

| improve this answer | |

I'm running ubuntu 13.04 and had a similar issue after upgrading from 12.10, I've managed to temporarily get around it, but unfortunately this needs to be redone after each reboot. If anybody can automate this process please let me know how. Thanks.

First we need to kill pulseaudio, -- but pulseaudio always restarts, so we need to disable that - Into terminal;

sudo gedit /etc/pulse/client.conf

change autospawn = yes to autospawn = no, and set daemon-binary to /bin/true. Make sure these lines are uncommented. Save, and close the file. Done, pulse audio will no longer restart after a crash or force close.

Next run,

sudo gedit /etc/bluetooth/audio.conf

and under General add


close and save the file. Run in terminal;

sudo service bluetooth restart

run in terminal;

pulseaudio --kill

now connect to the bluetooth device (I've tested this using BLUEMAN). Run in terminal;


then in a different terminal window;

sudo gedit /etc/bluetooth/audio.conf

remove Socket, leaving Enable=. Save and close the file and run in terminal;

sudo service bluetooth restart

connect to your bluetooth device again; - and it should (hopefully) work.

| improve this answer | |
  • This is good information, but for more assistance please open a new question. Thanks! – belacqua Jun 9 '13 at 0:05
  • This is some crazy stuff, but it was the only way I got a2dp working, thanks for sharing! Have you ever found a better solution? – Teresa e Junior Oct 25 '13 at 17:00

I had the same problems after upgrading from 12.10. After removing all configuration files from my home directory and reinstalling from scratch bluetooth ad2p was working again. Not the most ideal solution, but it worked.

| improve this answer | |

I had the same problem. My problem was, that avahidaemon crashed.

  1. sudo service avahi-daemon start #start avahi
  2. sudo service bluetooth restart #restart bluetooth to connect to avahi again
  3. sudo pactl list cards short #get name auf bluetooth-card
  4. sudo pactl set-card-profile <> a2dp #For me sudo pactl set-card-profile bluez_card.00_1E_7C_01_6D_45 a2dp

Hope this helps.

regards Anton

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.