0

On a clean 13.04 install, I have registered facebook in the online accounts, authorized facebook to allow ubuntu access, and installed the app.

But still I am not getting the facebook shortcut icon in the envelope menu (that I used to get in 12.10) at the top right. Please help.

Slightly off topic, but for pidgin, now I am getting an icon integrated in the envelope drop-down, instead of a seperate icon on the systray i had got in 12.10.

Now its not shown, even if I have facebook actually open in browser....any help?

  • I did another clean install of 13.04 and this is definitely an issue. Can anyone help on this please? – charlie May 4 '13 at 12:22
  • does facebook.com show in the output of gsettings get com.canonical.unity.webapps allowed-domains and gsettings get com.canonical.indicator.messages applications ? – Mahesh May 7 '13 at 12:20
  • I get ['facebook.com', 'mail.google.com'] for the first command and ['empathy.desktop', 'GMailmailgooglecom.desktop'] for the second one. – charlie May 8 '13 at 0:59
1

Appearance of facebook in the output of gsettings get com.canonical.unity.webapps allowed-domains indicates that you have accepted and installed the integration plugin.

gsettings get com.canonical.indicator.messages applications shows the list of applications that actually have an entry in the messaging menu. Facebook appears missing in your case.

Solution:
Check if the file /home/$USER/.local/share/applications/facebookfacebookcom.desktop exists. (replace $USER with your username.)

If it doesn't, remove facebook from com.canonical.unity.webapps allowed-domains (Use dconf editor. com>canonical>unity>webapps). This will cause firefox to prompt again, accept, and the desktop file should appear.

Open dconf-editor and add the filename facebookfacebook.com.desktop to com.canonical.indicator.messages applications. The facebook indicator should now appear in the messaging menu.

| improve this answer | |
  • @Mahesh....okay..so the file was there, but there was no entry in com.canonical.indicator.messages applications. So I added the filename, and tried, restarted and tried etc etc...nothing worked... Then I removed the entry from unity > webapps, and re-accepted the prompt on site visit....this time the entry was created at both locations in dconf editor...but still no facebook icon. – charlie May 8 '13 at 18:33
  • I removed the desktop file, removed it from both locations in dconf editor, and re-accepted the site popup....everything was regenerated all, right...but still no facebook icon – charlie May 8 '13 at 18:38
  • @charlie Try sudo apt-get install --reinstall unity-webapps-facebookmessenger – Mahesh May 8 '13 at 18:39
  • Tried that too, still nothing :( – charlie May 11 '13 at 21:58
  • I'm out of ideas, sorry.. – Mahesh May 12 '13 at 1:55
0

I heard about twitter and facebook integration in Ubuntu Raring using the Friends App (Gwibber re-written) and installed it as a desktop client.

sudo apt-get install friends-app

...and viola! the facebook icon appeared in the envelope menu!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.