I have been unable to restart, shutdown, or log out of ubuntu since the release of 12.04. I have upgrade at the time of release for 12.10 and now for 13.04 and have had no change in the situation. On logout or restart i get a solid black screen where it just sits.

I have let it sit for long periods and I get a message every 2 minutes or so stating something about Xorg blocked for 120seconds. I have search extensively and can't find anything that actually fixes it. Using the shutdown now command works from terminal with -P -r. Updating grub had no effect. Any clues or help would be great.

  • What hardware? sudo reboot should reboot the system sudo poweroff should shut it down; I see no reason it cant logout and let you switch accounts – GM-Script-Writer-62850 Apr 30 '13 at 3:15
  • only "sudo shutdown -P now" or "sudo shutdown -r now" work. I'm using a Toshiba Satelite laptop from 2006. I had no issues with Ubuntu 11.10. The issue seems to be related to Xorg being blocked and never being able to shut down fully. The laptop uses an integrated intel graphics gma945 express chipset if I remember correctly. I figured it was a bug of some sort when upgrading to 12.04, but 2 distros later and I still have the same issue. – schonjones Apr 30 '13 at 3:41
  • What about sudo halt I have had that not work on some systems under certain distros; is this a clean install of raring? – GM-Script-Writer-62850 Apr 30 '13 at 3:53
  • "sudo halt" appears to work, however it gives me a init_halt not found error 2 lines above system halted and after turning off the power the system locked up during POST the first 2 times I tried powering it on. If I use the gui reboot, log off, or shutdown commands after I ctrl+alt+del when the system is stuck it also freezes during post until I shut it down. Using the "sudo shutdown -r now" i have no issues on the reboot. – schonjones Apr 30 '13 at 15:06
  • You should edit grubs GRUB_CMDLINE_LINUX_DEFAULT line, remove "quiet" and replace "splash" with "nosplash". Update grub and after restart you should be able to see where exactly does the shutdown hang. It is also possible to add boot parameters temporary at the grub boot menu by pressing “e” while certain menu entry is select. Boot parameter should be added to the line that starts with “linux” and to boot with these settings press f10. – Tanel Mae May 4 '13 at 11:34

Ok, this is usually a hardware issue but could be drivers. Normally if you see it related it X it's a stale video driver. Try updating your video drivers. Finally you can always

echo 0 > /proc/sys/kernel/hung_task_timeout_secs

This will effectively quite is symptom but the problem will remain. This is certainly related to either failing hardware or bad drivers. The fact that you can actaully reboot via command line leads me to believe that it's a bad video driver. Make sure your running the latest video driver and that when you upgraded to 12.04 you kept using the same driver you were using when it was working (open v.s. propitiatory).

Another thing to look at is making sure you don't have any network shares mounted. When you log out of X network manager terminates a wireless connection. This will cause the system to hang for several minuets per file system read. During shutdown this can be quite a lengthy process. The quick test/fix is make sure all remote shares are unmounted before logging out. If that is the case then you should try adjusting your mount commands to show that they are network mounts and should be unmounted before you turn off the wifi connection. This varies by file system and mount type.

  • where should this line be added? I'm using Intel integrated gma950. I have gone through several drivers over the years at one point it was stuck on gallium and I had a difficult time getting it set back up correctly. I used the experimental line of drivers for a while and for some reason I only have 3 resolutions to choose from. – schonjones May 6 '13 at 4:24
  • The GMA950s have always had odd problems, try the command (as root) and see if you can reboot from X. If you can, then your probably fine. If you still can not then your only choice may be to be to try to trouble shoot your config by running from various LiveCDs and seeing if you can get any of them to work. – coteyr May 6 '13 at 4:45
  • I reinstalled the intel video drivers and uninstalled apache as it also liked to hang, can't remember why I had installed it in the first place. Still hangs now without telling me anything useful. What configs should I be looking at specifically. I'm not really sure what I'm looking for. I know logout does not work from a terminal window as I had tried that before. I'll have to check on shutdown and get back with you. Live cd for 12.10 works fine. – schonjones May 6 '13 at 5:21
  • "sudo shutdow -r now" does not work from a terminal window. I am unsure how to print the output from "ps aux" to a file and it is longer than the screen so I can't see everything running. I rarely ever restart or shut off my computer, but with all this work on getting it to work recently I've noticed an occasion error when I log in. "ubuntu 13.04 has experienced a problem" when I ask for the details it only tells me "usr/bin/Xorg". I send the happy little error report and go on my merry way with no noticable difference in the session. also an error related to nn-something. – schonjones May 6 '13 at 15:37
  • nm-applet is the other thing crashing on occasion. figured out printing "ps aux" to file. It's located at pastebin.com/TMcBAtHS – schonjones May 6 '13 at 16:55

Found this. It may help!

Originally Posted on Ubuntu forums. The problem hasn't happened to me again since disabling visual effects (Compiz Fusion). I have no steps to reliability reproduce the problem; so, I am not sure if it is solved or not.

Try to disable visual effects by:

  1. right click on the desktop and select "change desktop background".
  2. Click the "Visual Effects" tab.
  3. Change it to none.

This is a per user setting and (as far as I know) has to be changed for each user using the machine.

  • I got rid of compiz as it was constantly giving me issues. I'm using openbox and razor-qt at the moment. Unity started to give me all sorts of issues with the upgrade to 13.04 and is slower than I would like. – schonjones May 6 '13 at 4:20

Did you make a clean install of 13.04 or just upgraded over 12.04 ? It's recommended to make clean installs as many things change between versions. In fact 13.04 comes with lot of changes, you should try to install make a clean install (in case you haven't).

I see you are using "shutdown" command with no luck ... Have you tried with "sudo halt" still you have to use the terminal, but AFAIK "halt" should do the trick.

  • It is upgraded in order 11.10 - 12.04 -12.10 -13.04. it would be very difficult for me to back up everything I have and reload it. I have 80gb of Digital Negatives and nowhere else to store them at the moment. I have a second partition, but it's a small partition of only 10gb for a windows install I only use for itunes very rarely. – schonjones May 7 '13 at 2:11
  • also,halt does just that. halts everthing and just sits there. – schonjones May 7 '13 at 2:53

Try the link listed below. I looked it up online and the author has an interesting article about shutdown troubleshooting at the top of the web page. He mentions about looking into your log files for any errors messages related to your shutdown and restart issues and other stuff that i wouldn't think of when trying to troubleshoot an issue like this.


  • 2
    You should always avoid to force computer shut down by holding down the power button as there is high risk of data loss, breaking your system or damaging your hardware. If your computer has such problem it should be fixed. – Tanel Mae May 5 '13 at 8:32
  • 1
    Tuxest - There is not a 'high' risk of data loss or even hardware damage. A forced power cycle will result in memory data loss, but usually not operating system failure. Sometimes a couple of inodes need cleaning though. It's also very unlikely (but not impossible) to cause hardware failure. The problem should be fixed, but don't scaremonger the users. – Martin Owens -doctormo- May 6 '13 at 18:42
  • Martin - Yes, saying "high risk" might have been overestimation but the point was not about the risk level when doing such thing once. Rather my comment was about risks involved when adopting such approach to problems as regular (daily?) practice - thereby probability of unlikely events increases. In any case the original answer has been updated, so removing down vote. – Tanel Mae Apr 28 '14 at 5:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.