4

I recently installed Ubuntu 13.04 in dual boot with 12.04.1.

The problem I have is with the Bluetooth not working. I've tried searching for my phone, but no luck. I've installed Blueman and still no go. Bluetooth is working just fine on 12.04.1, but on 13.04 it is simply dead.

Personal file sharing is enabled on both versions, visibility is enabled but no matter what I do I can't get it to work. This is really annoying. How can I fix this problem?

| improve this question | | | | |
5

I figured it out myself. Something was not installed by default for Bluetooth. So, I went and installed Synaptic again and installed the following packages:

sudo apt-get install \
    bluetooth blueman \
    bluez-hcidump bluewho python-bluez  bluez-tools \
    brcm-patchram-plus-nexus7

One of these fixes my Bluetooth problem, and now it works just fine both ways (PC to Phone, Phone to PC). I forgot to mention that the problem occur immediately after a fresh install of Ubuntu 13.04.

It was stupid of me that I didn't test the Bluetooth before a clean install, but now it's all good.

(Previously in the question stated as a solution, this will help future users more easily.)

  • That worked for me on Ubuntu16.04. Also, brcm-patchram-plus-nexus7 is obsolete, use bluetooth-touch instead. – Leogout Feb 7 '18 at 17:49
  • Same with me installing the previous list of packages without needing to install bluetooth-touch + cold reboot, solved the problem. However I did try a bunch of other stackoverflow answers (+reboot) before the cold-reboot. So can't really say what fixed it. – petobens Nov 30 '18 at 18:19
1

In Ubuntu Software Center search for: Bluetooth Support.

This package provides all of the different plugins supported by the Bluez Bluetooth stack. I've also installed Blueman.

| improve this answer | | | | |
  • This is essentially the GUI equivalent of the command line community wiki method answered by @Alvar – StackExchange What The Heck Dec 10 '13 at 15:00
0

This worked for me:

  1. Open /etc/bluetooth/audio.conf, by typing this into a terminal:

    gksu gedit /etc/bluetooth/audio.conf
    
  2. Find Enable = ... under [General] and delete Socket from the list

    [General]
    Enable = 
    
  3. Add this line:

    Disable = Socket
    
  4. Save the file.

  5. Restart the bluetooth service

    sudo service bluetooth restart
    
  6. Restart pulseaudio for good measure.

    pulseaudio -k 
    pulseaudio -D
    
  7. Cross your fingers.

| improve this answer | | | | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.