I just installed from the DVD-ISO image over Ubuntu 12. System will not boot from HD. I can get grub2 menu and have tried the nomodeset option. However, even in recovery mode, the system hangs when trying to start in fail-safe X-mode. I just get a black screen with blinking cursor. Even worse, system doesn't respond to Alt-Ctrl-Delete and requires a system power down to get restarted!

Yes, I have an NVidia card (550-ti) which is mature and pretty generic. Any suggestions ?

I can boot from the Live-DVD, but can't adjust monitors or get X-config for NVidia running from the Live version. After disabling 'quiet' in the boot cmd, I can see it run through and auto-login after which it just blinks the cursor with no further msgs.

  • I did boot to a recovery screen and updated to the latest nvidia-current and nvidia-settings from the ppa repository. These seem to have been in the ISO download anyway as versions were reported as current. Still no joy, just a blinking cursor line after attempting to start X in fail-safe mode. – user169066 Apr 27 '13 at 19:20
  • Completed a clean install from the DVD with updates disabled, just the disk files and what they pull from the net. System did boot to Desktop though does not recognize my monitors and leaves me at a 'mobile' resolution of 1280x??. I then changed from Nouveau to the Nvidia driver on the options page. Attempting to reboot failed. Attempting to reboot to recover provided its menu, but launching 'failsafeX' just hangs with a blinking cursor and requires a power cyle. – user169066 Apr 28 '13 at 16:53
  • I'd just like to add that I'm having to do all the diagnostics, etc (like sending this msg) from MS-Vista! What's really frustrating is trying to get Grub updated since now it can't even reboot unattended but instead has to be hand held to get to Vista. And 'grub2' tools aren't readily available, even as 'Startup Manager' or whatever it was before even within Ubuntu's System settings. – user169066 Apr 28 '13 at 17:05

Your almost there, it looks like the Nouveau kernel module might be the problem. Blacklist it in modprobe.d by editing "/etc/modprobe.d/blacklist.conf" and add these lines.

 blacklist nouveau

 blacklist lbm-nouveau

 blacklist nvidia-173

 blacklist nvidia-96

 alias nvidia nvidia-current 

then rebuild initramfs with

sudo update-initramfs -u

reboot and do lsmod to see if any nouveau modules are loaded. If not, then do the NVidia installer.

  • Thanks! I'll give this a try. I should be able to get to a 'root' from the recovery menu and avoid an install from the DVD again. It is a bit disappointing that the 'failsafeX' still fails to 'just work'. Will report back on results. – user169066 May 1 '13 at 20:24
  • No joy! No nouveau modules were listed by lsmod after the initiramfs update, though I couldn't get a prompt after the reboot to see if any were present. System still just hangs with blinking cursor. This is especially annoying when defaulting to the failsafeX mode (which isn't at all failsafe). The DVD doesn't have any problem with default graphics. "failsafeX" needs more work. – user169066 May 10 '13 at 16:40
  • And by the way, the filesystem needs to mounted as r/w before entering as root from the recovery menu. This took a while to figure out. Checking grub or dpkg works though this isn't very intuitive. I did try xdiagnose from the recovery root option, and watched it check its startup stuff, but then fail when unable to open a display. I do have two displays and did try disconnecting the secondary,but it didn't make any difference. – user169066 May 10 '13 at 16:44
  • Tried again for awhile today and started digging into the logs a little deeper. Hopefully, this will help @mastrof3d. – user169066 May 14 '13 at 18:56
  • No Nouveau modules shown loaded by lsmod. – user169066 May 14 '13 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.