6

I installed Ubuntu 13.04, but after the reboot theres only a black screen with the blinking bar on the top left. I found, that one possible solution is that the video drivers are not installed, so i tried it (the weird thing is that "try ubuntu without installing" works perfectly fine). So i downloaded the .run file, but it's always saying "seems like you're running a X Server" blahblah. I searched for maybe 2 hours for the solution, but none of the ones i found worked for me. Can anybody please help me? PS: I'm pretty new to Ubuntu...

8

2 Answers 2

5
  • There is a bug with nvidia and the stock 3.8.0-19 kernel in ubuntu 13.04 use the mainline kernel
    • Not doing this can result in not being able to boot
  • Install the driver by running sudo apt-get install -y nvidia-313-updates nvidia-settings-313-updates
    • If you want the beta driver use the xorg edgers ppa, then install nvidia-319 nvidia-settings-319
      sudo apt-add-repository ppa:xorg-edgers/ppa -y; sudo apt-get update; sudo apt-get upgrade -y; sudo apt-get install nvidia-319 nvidia-settings-319 -y
10
  • I fail at the first step, i tried it with the .zip file and the file named "install" in the .zip file, but either way it says: "bash: /*path*/install: Permission denied" And i even logged in with root user EDIT: I needed to change the permissions :D
    – Julian
    Commented Apr 27, 2013 at 17:50
  • Use the terminal commands work every time :) (the script will ask for your password when needed) When someones says /path/to/ that means the same thing as foo/bar or fill in the blank Commented Apr 27, 2013 at 17:58
  • Now it says "Package nvidia-settings-313 can't be found." (I hope i translated it correctly :D)
    – Julian
    Commented Apr 27, 2013 at 18:04
  • fixed: I missed "-updates" when i typed that one (see answer); don't forget to install the new kernel after running the last command in the instructions (run /tmp/kernel-update) Commented Apr 27, 2013 at 18:07
  • Now there's something weird... After telling me i need 209 MB free space on my hdd it asks me if i would like to continue. when i say "y" it says "cancelled"........ And i dit install the new kernel :D
    – Julian
    Commented Apr 27, 2013 at 18:10
0

nvidia has now different packages - so it happens, that certain graphics-card is only working best with a certain package. sometimes it lasts longer then, until one has found the proper package for the certain card.

e.g. optimus CUDA - they are not supported by included nvidia-packages of Debian/Ubuntu fully - instead they seem to be fully supported only by package:

NVIDIA_CUDA_SDK_1.1_Beta_Linux.run

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .