After a fresh install of Ubuntu 13.04 64-bit, my wifi is now misbehaving. It seems to lose Internet connectivity from time to time, so this results in, for example, the web browser stops loading sites at the middle of the process, wait ~3 seconds, and then receive the rest of the site. This didn't happen in 12.10, in the same laptop.

Another symptom that anounced that something was not going to be alright, was the wifi disconnecting for a moment when I hit "Continue" in the first stage of the Ubuntu installer, in the screen where you select "Update during install" and "install MP3 support".

I have a Broadcom BCM4313 card (actually it's a "Dell WLAN 1501" card, but at this moment I don't understand very well how this two brands relate to each other)

~$ lspci -vvnn | grep 14e4
12:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)

I've read that this might be a bug in the current driver shipped in Ubuntu 13.04: bcmwl-kernel-source

How do I downgrade to a previous working version?

I tried following this instructions but 1) I can't install the old version from the repository because it doesn't seem to be available for Ubuntu 13.04. and 2) If I manually download and install a .deb file from here (bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_amd64.deb) , after reboot the system drops the wl controller and selects again the brcmsmac controller, as shown in the "connection information" dialog screen from the notification area. Then, if I try to select it manually, I get:

~$ sudo modprobe wl
FATAL: module wl not found.

Does this have something to do with the kernel version? i.e. the .deb package not being compatible with my current kernel. Any ideas? Maybe I have to recompile that source package? If so, how?

Thank you.

2 Answers 2


I managed to downgrade the wireless driver but I still have the same problems. I also tried other drivers such as bcma and even ndiswrapper (Windows drivers) and the problem persists. I believe the problem is in the new kernel, so it seems I'll have to go back to 12.10.

Having installed Ubuntu since 11.04, from my experience, it gets harder in every Ubuntu release to get the same wifi card working...

Anyway, if it's useful for someone, this is how I downgraded the driver:

First, uninstall the current driver and install the new one from the .deb file.

sudo apt-get remove --purge bcmwl-kernel-source
sudo dpkg -i /deb_file_location/bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_amd64.deb

Lock the package version to prevent updates.

pkexec gedit /etc/apt/preferences.d/bcmwl-kernel-source

and paste in the pollowing:

Package: bcmwl-kernel-source
Pin: version*
Pin-Priority: 1001

I also blacklisted the other modules to be sure that they don't get loaded on boot, but this may not be necessary in all cases.

pkexec gedit /etc/modprobe.d/blacklist-bcm43.conf

and add the following:

blacklist brcmsmac
blacklist bcma

Reboot and done. You can check that the driver is in use by typing:

lspci -k | grep wl

Which should return:

Kernel driver in use: wl

+1 for the WiFi problem. I have a Dell E6510 with the BCM4313 wifi and ever since the 13.04 upgrade WiFi has been bouncing up and down several times an hour. It is mostly reconnected very fast. I've noticed that after suspend/resume although I will typically have WiFi, if it drops after that then I start getting prompts to enter my wireless password and it wont reconnect until I reboot. Grrrr.

Just now I tried turning off power management for the WiFi, I will see how that works out.

sudo iwconfig wlan0 power off

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .