18

I want to limit transmission to work at 02:00 AM untill 08:00. How?

20

The Speed Limit in Transmission throttles the upload/download speeds during the time set. What you want to do is set the upload/download speed values to 0 and implement that starting at 0800 and end at 0200. That should deactivate all uploads/downloads starting at 8am until 2am the following day.

transmission preference

  • You can always set a general throttling policy in Transmission to limit bandwidth usage. If you modify the Speed Limits for Scheduled Times: as I explained, that will enable uploads/downloads only between 2am and 8am as you wanted. The settings you had entered disabled uploads/downloads during the time you actually wanted it to be active. – douggro Apr 27 '13 at 16:14
  • 1
    No, more like this. – douggro Apr 27 '13 at 21:03
  • 5
    I've just tried this, but it's not an ideal solution I think. Transmission still connects to peers so it's still active. Do you know of a way Transmission is completely inactive between certain periods of the day? – duxk.gh Sep 8 '13 at 14:28
5

I was going to use the above scheduled throttling, but thought of something additional and that is to just use the cron daemon via a start and stop: (e.g. Add the following to cron jobs via crontab -e)

 * 2 * * *  sudo service transmission-daemon start
 * 8 * * *  sudo service transmission-daemon stop

for you 2am-8am schedule. Perhaps even start it a little (5 minutes?) earlier/later?

The only problem I see from this though, is that the service won't be running during the day, when you want to add new torrents. So you'd have to start/stop manually whenever you are adding torrents (per "session")

Depending on your habits, this may/may not be convenient...

  • 1
    Welcome to AskUbuntu! ;-) The existing answer is a bit simpler to implement then yours, but yours would consume less memory.. But you need to enable the daemon (which is lacking in your answer) There also is a spelling error in your output and your answer does not contain the crontab command to make this work. Therefore: please update your answer to make it a full-fledged working solution and drop me a note @Fabby so I can upvote it, or delete this answer altogether to get rid of the negative reputation points you now got... – Fabby Feb 5 '15 at 13:25
  • Thanks. The spelling was a bad typo, sorry. I've assumed the OP already has the daemon enabled etc, but added what I thought you meant about crontab command... My answer was really intended as a response to the comment from @duxk.gh - but Stack exchange doesn't let those under 30rep comment (but I can answer?) – Matt C Feb 6 '15 at 1:26
  • There. made it a bit more "professional" and upvoted. Always use the logic of the person asking 2AM-8AM, so also put the start/stop in that order... Review my edits: askubuntu.com/posts/581994/revisions – Fabby Feb 6 '15 at 7:20
  • I'm on ubuntu 16.04 and there is no service with that name transmission-daemon ?? – azerafati Jan 17 '17 at 20:44
  • @Fabby the graphic UI didn't works from me , and it more confuse even I select slow download transmitter still download the files on day time ! Sadly this solution didn't work wither I got Failed to start transmission-daemon.service: Unit transmission-daemon.service not found. – Salem F Nov 30 '18 at 11:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.