8

I added the Japanese Layout in Keyboard preferences, however all the layouts look like being in katakana.

I suspect that the key that is left of number 1 (above Tab and under Esc) could be the one to switch from katakana to hiragana however I don't have that key in my keyboard and my other Toshiba laptop does not have it either. I really don't know what to do, I simply want to be able to write in hiragana in Ubuntu.

Thanks

9

I'm not sure that the "Japan Kana" layout can do hirigana. The key left of 1 doesn't toggle for me.

I've only ever used an IME to type Japanese, that might be an easier option for you - you type phonetically in romaji and it's converted to kana and kanji. A guide to installing it is here:

http://www.localizingjapan.com/blog/2010/06/15/setting-up-japanese-input-on-ubuntu-linux-10-04-lts-lucid-lynx/

To write, you type in romaji, e.g. nihongo. As you type, that would be replaced by hirigana にほんご. Hit space and that would be replaced with the kanji 日本語. Hit space again and you get a menu of other ways to represent it, which is important as Japanese has many homonyms.  

  • 2
    Thanks, still I want to type directly in hiragana. I hate writing in romanji and the keyboard has hiragana printed on the keys. Most japanese keyboards come with hiragana next to romanji so there should be a way to write in hiragana. – Lisandro Vaccaro Mar 2 '11 at 15:38
8

I finally found out how to do this on Ubuntu 16.04!

  1. Go to System Settings > Language Support
  2. Click on Install / Remove Languages
  3. Scroll down or type J and check the checkbox next to Japanese in the Installed column. After this, click on Apply Changes
  4. Enter your password when you're prompted
  5. Let the packages install
  6. Log out (yes, this is necessary)
  7. Open System Settings and go to Text Entry
  8. Click on the small plus sign at the bottom of Input sources to use
  9. Select the entry Japanese (Mozc) (IBus) from the list and click on Add
  10. Japanese (Mozc) (IBus) should now show up inside the Text Entry window and Mozc should be available in the menubar's menu. You probably want to change the setting Use the same source for all windows to Allow different sources for each window and switch to New windows use the default source. Additionally, you eventually want to reassign the key to switch to the next input source. I normally use the Pause to toggle between languages.
  11. Now fire up some text editor and try it by clicking on "Mozc" in the text entry menu, set the input mode to hiragana and type some Japanese. Switching between candidates is done by pressing the space bar and Katakana conversion is done by pressing F7.

Note: If you face any issues with different applications, it might help to restart the IBus daemon using ibus restart.

See also the original article archive.is by Moritz Molch. There are also screenshots there, which should make everything a little clearer.

1

I don't know Japanese and don't have a Japanese keyboard, but I think I might have found what you're looking for.

The key is IBus. Fire up IBus Preferences and install the Japanese "anthy (m17n)" input method. Then, configure IBus to show the language bar when you activate Japanese mode. If you don't have the proper key on your keyboard to toggle the input method on and off, you can configure your own. I use the Pause key for this. Annoyingly, you can't add a key directly from the preferences window, but you can do so easily enough from within gconf-editor.

When you type, you should be able to get hiragana directly. If not, play with the language bar settings and you'll surely find what you're looking for.

0

Following up... on my system, in Kana mode keypresses generate hirgana and Shift-keypresses generate katakana. Logical if you think of katakana as upper case and hiragana as lower case.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.