22

I consistently get two login screens!

I enter credentials correctly and am immediately presented with a second login screen (no errors). Authenticating against the second screen completes a normal login to the Ubuntu desktop.

The above is a quotation from a problem reported on 7. May 2012 by Soren Mogensen. See User login cycles. I have the exact same problem, and was hoping that Soren might have received an answer which would enlighten others, but unfortunately Soren's problem was reported as part of an "answer" to another problem, and the only "solution" on that occasion was advice to create a new question.

I can login, I just have to present my credentials twice, so this is NOT a duplicate of any "unable to login" problem. My concern is that this looks like a classic phishing setup, where one of the two login screens is a fake designed to harvest my ID and password for some nefarious purpose. If Ubuntu has been susceptible to phishing attacks for nearly a year now, then I imagine that would be a matter of enormous concern.

  • 1
    Here a bug that could be related bugs.launchpad.net/ubuntu/+source/linux/+bug/1296270 – Postadelmaga Apr 24 '16 at 2:54
  • 1
    I'm seeing this on an Ubuntu GNOME installation. The top-rated answer below is not plausible because Package 'gnome-screensaver' is not installed, so not removed – Charney Kaye Dec 2 '17 at 19:34
  • Just to re-iterate @charneykaye comment: this does not work on Lubuntu 16.04 where gnome-screensaver is also not installed. – Yannis Jan 10 '18 at 15:22
  • it seems (by my own passive self-observation) this issue is avoided if I wait a few seconds before entering my info, after boot/wakeup. – Charney Kaye Jan 23 '18 at 19:46
13

Uninstall your gnome-screensaver,

sudo apt-get remove gnome-screensaver

Then, reboot. It works for me, now only unity login screen appears.

  • 1
    this worked for me on 16.04 – Postadelmaga May 11 '16 at 1:40
  • Worked for me on 14.04. Don't forget to restart! I had to force a reboot. – wjandrea Jul 4 '16 at 19:03
  • I can confirm, this worked as a solution on another related question +1 – Mark Kirby Sep 29 '16 at 13:43
  • And, the screensaver also keeps working after. – Berci Oct 31 '16 at 0:00
1
  1. Try sudo pstree

    You should look for the Xorg process and see what parent it has. Is that parent process lightdm?

    Then you're using the LightDM display manager, and it's proboably a LightDM issue.

  2. Install another display manager, GDM

    sudo apt-get install gdm
    

    During configuration of the package, set GDM as the display manager.

    Does the problem still exist? Now you're sure it's a LightDM issue.

  3. sudo dpkg-reconfigure lightdm
    

    Now LigthDM is back.

  • Thanks. The parent process of Xorg was KDM. I switched to lightdm, got the message Please be sure to run "dpkg --configure lighttdm", so I did that (with sudo) and got the message. – MTGradwell May 5 '13 at 18:23
  • Thanks. I'm trying to post a multi-paragraph response here, but every time I press return it seems to post my message instead of starting a new paragraph. Anyway, the parent process of Xorg was KDM. I installed and switched to lightdm, and got the message 'Please be sure to run "dpkg --configure lighttdm"', so I did that (with sudo) and got messages 'package lightdm is already installed and configured' and 'errors were encountered while processing: lightdm'. The system now hangs on reboot, so I'm working on rebooting without the GUI in order to then get things back the way they were before. – MTGradwell May 5 '13 at 18:48
  • Now I've got it booting again and set GDM as the display manager. I still get two login screens in succession but they look different now, and are accompanied by a musical note. – MTGradwell May 5 '13 at 19:06
  • Getting weirder. I've switched to lightdm again and this time it doesn't hang, but now it boots straight to the desktop. I'm able to use the desktop for a minute or two, and only THEN does a login screen appear. – MTGradwell May 5 '13 at 19:36
  • Finally I've switched the display manager back to KDM, which is what it was originally. I still get two login screens, one after the other, but since the alternative display managers seem to be as bad or worse, I think I'll leave well alone. Thanks anyway for the help. – MTGradwell May 5 '13 at 19:46
-1

This solution seems to work for some as it looks like an ongoing problem depending on circumstances - Look in your system settings for "Lock Screen" in all possible applications.

  1. Search dash or in system settings go to Brightness & Lock then turn lock off.

  2. Check in other apps like Unity Tweak Tool > System and uncheck Desktop lock.

  3. Open a terminal and navigate to /var/log/ then use less auth.log and check the log then check to see what happens at start if there any errors. Look out for pam-wallet issues like directory not found, error opening it. If you see wallet errors then try reinstalling - sudo apt-get install --reinstall pam-kwallet then sudo apt-get -f install && sudo apt-get autoremove && sudo apt-get -y autoclean && sudo apt-get -y clean finally sudo apt-get update. Reboot machine.

  4. Reconfigure lightdm using commands below one by one

    sudo apt-get purge lightdm
    sudo apt-get install
    sudo apt-get install lightdm
    sudo dpkg-reconfigure gdm
    
  • 2
    that last set of commands is nonsense? – Zanna Jun 25 '17 at 6:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.