160

When I double-click on a script in Nautilus to run it, the script just opens in my text editor with no option to run it. Using Nautilus, how do I run executable text files and/or scripts?

12 Answers 12

201
  1. Open Nautilus.

  2. Open this from the menu bar:

    Edit → Preferences

  3. Select the 'Behavior' tab.

  4. Select "Ask each time" under "Executable Text Files".

  5. Close the window.
  6. Right click the file, and select "Properties.
  7. Select the "Permissions" tab, and make sure "Allow executing file as program" is selected.

  8. Close the window.

Now you can double-click your executable text file in Nautilus to be asked whether to execute or edit your script.

enter image description here


Answer credit: Nur

  • 23
    What a weird default to have. And not even a right-click option to just run the file. Very unfriendly to users. – RomanSt Sep 11 '14 at 22:59
  • What about I want it to always run in terminal? – Derek 朕會功夫 May 5 '15 at 17:08
  • 3
    On step #2, "Open this from the menu bar"... where is the menu bar? I don't see an "Edit" menu anywhere. I see my files in the middle, several local and network locations on the left, and a menu button in the top right which just has buttons such as "new tab" and undo/redo. The top just has the back/forward buttons and the list of folders I'm in. – Aaron Franke Jun 3 '16 at 0:44
  • @AaronFranke: In ubuntu the menu bar shows when you hover the dark bar on the top of the screen. – Stefan Monov Dec 9 '16 at 14:25
  • 1
    @StefanMonov I'm using Xubuntu, not Ubuntu, and so I don't have a dark bar at the top of the screen. – Aaron Franke Dec 10 '16 at 9:23
35

Follow these steps:

  • Install dconf-editor because it isn't installed by default.
  • Hit Alt+F2, type dconf-editor and hit Enter.
  • In dconfg-editor goto: orggnomenautiluspreferences

    enter image description here

  • Click on executable-text-activation and from drop down menu select:

    launch: to launch scripts as programs.

    OR

    ask: to ask what to do via a dialog.

  • Close dconf-editor. That's it!

  • 6
    You can also open nautilus, click Files > Preferences, check behaviour tab, and select the option you prefer for Executable Text Files, open with text editor is the default. – Nur Apr 27 '13 at 14:03
  • Next solution is easiest way of doing :) – mac May 9 '13 at 6:24
  • Although this works too, dconfg-editor is the worst possible way of changing application configuration. – Benjamin May 5 '14 at 18:15
  • This answer was very helpful for me, even though using the preferences dialog would "normally" be a better answer, as I'm using a tiling window manager and the "Files" menu appears to be completely inaccessible! – Ben Apr 27 '15 at 1:17
14

I think this is a nuisance caused by Gnome people who decided to change that default behavior we were accustomed to.

To fix it, you can;

  1. install (if you haven't already) and start dconf Editor,
  2. go to: org > gnome > nautilus > preferences, and
  3. change the value for executable-text-activation back to ask (or even launch, if you prefer).

If you want the same Nautilus behavior as Root as well you can repeat the steps above, starting dconf Editor this time as Root.

12

in a terminal

gsettings set org.gnome.nautilus.preferences executable-text-activation ask
  • +1: This works in older versions of Linux, even before the dconf method became available. – Alex Mar 31 '17 at 16:17
  • 1
    This should be the accepted answer, IMHO. – Andrei Gheorghiu Jan 29 '18 at 1:22
  • Is there a way to apply this same configuration for all users? (Either for all existing users, or for all users created in the future, or both?) – Wildcard Oct 12 '18 at 10:28
  • I believe yes. im not sure how to do it. maybe you can update it in /etc/profile or /etc/bash.bashrc – OmaL Oct 12 '18 at 10:48
5

Change Nautilus' Behavior with Executable Text Files

  1. Open Nautilus
  2. Files > Preferences
  3. Go to Behaviour tab
  4. Select Ask Each Time

screenshot of Files Preferences

Double-click your Executable Text File in Nautilus

Voila!


Answer credit: Nur, Jorge Castro

  • 1
    Duplicate of the Community Wiki... – Alex Mar 31 '17 at 16:18
4

GUI

  1. Depending on which Ubuntu version you have,

    • Before 13.04

      In Nautilus, open this from the menu bar:

      Edit → Preferences

    • 13.04 or 13.10

      In Nautilus, open this from the menu bar:

      Files → Preferences

    • 14.04 or 16.04

      In Nautilus, open this from the menu bar:

      Edit → Preferences

  2. Then, in the 'Behaviour' tab, select "Run executable text files with they are opened".

    Alternatively, select "Ask each time" instead if you would like a dialog (example) asking you whether to edit or execute the file.

    enter image description here


Command line

If you prefer a command:

dconf write /org/gnome/nautilus/preferences/executable-text-activation "'launch'"

Note: Both GUI and command line methods work only for Nautilus (the default graphical file manager in Ubuntu)

Originally from another answer posted by me here.

  • 1
    @DKBose: The command 'dconf' is in Ubuntu by default. dconf-editor only provides the GUI program to edit dconf. – kiri Feb 23 '14 at 8:43
  • You are correct. Sorry about that! – DK Bose Feb 23 '14 at 11:04
3

For that I guess the best way will be to make .desktop launcher, make that launcher executable using

chmod +x blah.desktop

And after that you will be ready to run it via just clicking, and even more you can add it to launcher. To read more about how to make .desktop files look here. Main part of it is this

[Desktop Entry]
Type=Application
Terminal=false
Icon=/path/to/icon/icon.svg
Name=give-name-here
Exec=/path/to/file/executable
2

You can do this for a single file by going into permissions in file properties and selecting "run this file as an executable".

enter image description here

1

You can use the most upvoted answer in Fedora 20 + GNOME too:

Open Nautilus, check Preferences -> Behavior -> Executable Files, put as always ask
0

You have to check 3 points :

0

right click on the file -> open with -> other application -> view all applications -> run software -> select

from now on shell scripts will be run on double click.

-1
  1. Open Nautilus. (File Browser)

    1. In Ubuntu 17.04, now we can cummulative bar so Preferences in available in Files.

    2. Open this from the menu bar:

  2. Files → Preferences

  3. Select 'Behavior' tab

  4. Select "Ask what to do" under "Executable Text Files".

    preferences

  5. Close it.

  • duplicate answer – wisbucky Aug 9 '17 at 18:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.