I made a clean install of 13.04 from a flash drive, but after a reboot the only uefi boot options I have are the basic efi shell entries and the flash drive again - there's simply no entry for 13.04.

So the first thing I did was boot up the live enviroment with the flash drive, chroot into the 13.04 install and work it out with grub-efi and efibootmgr.

First thing I notice, copying the resolv.conf doesnt seem to give me wifi-access in the chroot enviroment.

Second thing, trying to create a new efibootmgr entries doesnt do anything - I've tried a few bogus entries, but the verification always only shows me the default efi shell entries.

So my main question is: did they change anything about efibootmgr? Did anyone else manage to get 13.04 to boot up with uefi?

PS: this pretty much shows what commands I used if thats helpful. and this seems to indicate the problem existed in the beta release.

up vote 1 down vote accepted

I have heard of bugs in some versions of efibootmgr that can cause this problem. You might try using efibootmgr in an older version of Ubuntu or in a rescue system like System Rescue CD to bypass this bug, if it's the cause.

If that doesn't work, you can try copying the EFI/ubuntu/grubx64.efi file on the ESP to EFI/BOOT/bootx64.efi. If no other OS is installed, that should get it working. The Boot Repair tool will do this, and more, automatically; it should work even if Windows is installed.

If you've got a Windows installation, another option is to use bcdedit in Windows: Launch an Administrator Command Prompt and then type bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi. (If you've got Secure Boot active, you'll need to activate shim.efi or shimx64.efi [I'm not sure which it's called in Ubuntu, offhand] instead of grubx64.efi.)

  • booted into the live enviroment with the secure remix, boot repair recognized the efi partition and did its magic: voila, bootable ubuntu entry. thanks for the help – Spleen May 1 '13 at 10:01

A bug in 3.8 series kernels prevents creation of EFI variables (at least on many Asus and Gigabyte motherboards) and thus efibootmgr is unable to create any boot options (the utility itself simply quits quietly without displaying any messages but you can find this error in dmesg or by strace efibootmgr).

Unfortunately Canonical didn't fix this issue before release even though it was known, and it still doesn't seem to ship a kernel that works or efibootmgr that would print a proper error message. I hope that this gets fixed promptly. Otherwise my suggestion is to use an older version, e.g. 3.5 series kernels work on 13.04, or you could use 12.10 LiveUSB.

The upstream kernel patch that broke it: http://lkml.indiana.edu/hypermail/linux/kernel/1303.0/00887.html

I am not sure if upstream has also fixed the issue yet but there has certainly been discussion about it.

Ubuntu is still broken, related bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1167622

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.