I accidentally removed the trash icon from the desktop, is there a way to put it back?


Using the graphical tool GConf Editor :

  1. Alt+F2, type gconf-editor and click Run.

    enter image description here

  2. Navigate to apps ➜ nautilus ➜ desktop and check the trash_icon_visible checkbox.

    enter image description here

From the Command Line :

gconftool --set --type=bool /apps/nautilus/desktop/trash_icon_visible True  


In later systems GConf Editor/gconftool is outdated and the settings are not there.

Using Dconf Editor:

org > gnome > nautilus > desktop

enter image description here

  • I can't see apps/desktop/nautilus in gconf-editor – Ondra Žižka Jul 25 '17 at 15:03
  • 1
    @OndraŽižka - the answer was outdated - see my edit. – user47206 Mar 22 '18 at 9:36

If it's a desktop icon:

1) Press ALT+F2 and type in the dialog: gconf-editor + enter

2) In the editor, navigate to apps/nautilus/desktop and on the rigt hand pane check the "trash_icon_visible" checkbox

If it's the panel icon:

Right click on the panel, select "Add to panel", select trash (or something similar to that... sorry, can't remember the exact name, I'm translating from a spanish install).

  • Thanks, it was the latter, but it's good to know both! – Rob Mar 1 '11 at 23:42
  • I can't see apps/desktop/nautilus in gconf-editor – Ondra Žižka Jul 25 '17 at 15:03

If you put the trash icon in the trash just open any file manager window (nautilus) and select Go -> Trash from there you can restore the icon.

  1. left click on the desktop
  2. click on 'desktop Preferences'
  3. in the 'desktop' tab, in the end, click on the checkbox for 'wastebasket'

Desktop icons, including the Trash icon, have been disabled in Ubuntu 19.04 and later. To add them back install the Desktop Icons GNOME shell extension from Ubuntu Software.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.