When I went to watch some only episodes of star trek on Amazon Prime, the player would get stuck on updating. I followed the instructions here and doing so actually worked for 3 seconds. It was the oddest thing. Clearly the video was playing and I saw 3 seconds of the episode, but a message came up saying I needed to update my flash player. I tried loading videos over and over again, but no success, not even the 3 seconds. Here is the error message:

Sorry we were unable to stream this video. This is likely because your Flash Player needs to be updated.

I am running Ubuntu 13.04 Raring Ringtail, Firefox 20, and adobe flash-player 11,2,202,280. Apparently Adobe isn't going to make newer versions of flash available for Linux, only security updates.

So has anyone been able to play prime instant videos, and if so, under what circumstances? Is there perhaps an alternative implementation of the flash plugin I can use? Or is the cause of my problem something different altogether?

Problem probably has to do with the version of flash being used. If anyone has gotten Prime to work with an my current version of flash or an open-source/free implementation of it, please do tell. Or if anyone can get videos on amazon to play with any other parameters aside from changing my browser to chrome, please tell me.

This also affects protected content in Hulu and other services that employ DRM through Flash.

What hasn't worked:

  • Using Chrome which has the newest version of flash via ppapi. Amazon Prime strictly prohibits it.
  • Using Chromium has the same issue as using firefox
  • Trying to install Adobe Flash 11,2,202,275. Is not compatible with raring libraries(?).
  • I'm not going to post this as an answer since I'm not satisfied with it. So Adobe decided to make new versions of flash for linux using Pepper plug-in API developed by google instead of the Netscape plug-in API used by every other browser except Internet Explorer which uses Active X. Reasons why they did this would instill much debate. However, Amazon Prime requires I guess the newest version of flash which maybe is the problem. Anyone know any forks of firefox that has the ppapi? The only work around I can see is using chrome, which doesn't answer the question.
    – Nil
    Apr 27, 2013 at 1:34
  • 1
    I doubt it will help, but you can try Gnash, which is an open-source implementation of Flash. IIRC, however, it's outdated (I'm not sure though).
    – strugee
    Apr 27, 2013 at 2:02
  • 1
    I tried installed proper Google Chrome (not Chromium) as well. Had to symlink the old udev library to get it to run, but it still didn't work. Apr 27, 2013 at 2:26
  • 1
    @nil, you don't need to actually install libudev.so.0 as in 13.04 libudev.so.1 exists. If you simply force the install, ignoring the dependency check, then symlink libudev.so.0 to the existing libudev.so.1, you can get Chrome to run just fine. Apr 27, 2013 at 3:01
  • 1
    I don't think it's a flash issue now. I just looked on my 12.10 installation where it is all working just fine, it and it has the same version of Flash as on my 13.04 where it doesn't work. Apr 27, 2013 at 21:18

4 Answers 4


I did the following on 13.04 64bit:

sudo apt-get install hal

sudo mkdir /etc/hal/fdi/preprobe

sudo mkdir /etc/hal/fdi/information

/usr/sbin/hald --daemon=yes --verbose=yes

rm -rf ~/.adobe

That got things up and going in Chromium....

Commenters also confirmed that the same instructions work for 12.04 64bit.

  • 3
    This works beautifully. Better than firefox in wine! Would you mind explaining what the problem was and why this fix works? Also, I'm running the 32 bit version of raring, so it works for both versions.
    – Nil
    May 2, 2013 at 2:47
  • 2
    This fix also made it work in firefox. You are the man!
    – Nil
    May 2, 2013 at 2:51
  • 1
    Amazing! Would be great for someone to explain this a bit more though. Glad things are working again. From the fix, it looks like it was an issue with HAL. May 2, 2013 at 6:15
  • 3
    Apparently hal isn't working properly on 13.04. It is missing directories and not running when it is supposed to. Seems that hal functionality is being roled into udev.
    – Aaron
    May 2, 2013 at 17:13
  • 2
    Thanks for posting the solution. I understand that udev replaced hal, but since hal is still provided and still required for Flash DRM, perhaps a bug should be filed?
    – aap
    May 3, 2013 at 2:58

The other solutions here haven't worked for me in 13.10 64bit. The only thing that does is adding a ppa :

sudo add-apt-repository ppa:mjblenner/ppa-hal
sudo apt-get update && sudo apt-get install hal

That worked in Chrome.

Thanks Michael Blennerhassett for the ppa

Thanks omgubuntu for providing the instructions I got the answer from: http://www.omgubuntu.co.uk/2013/10/fixing-amazon-prime-streaming-drm-protected-flash-13-10

  • I can confirm that this also works in 14.04 64bit. In my case, I installed flash for Firefox, then installed HAL, and all worked perfectly.
    – Kim
    Nov 9, 2014 at 2:30

Code the Following:

sudo apt-get install hal


(This works for version 12.10 I apologized. I forgot I have not upgrade my laptop yet)

For version 13.04 ( I am running Xunbuntu on my Desktop)

In my case I did have to download hal and run hald

then I made the same changes from the answer above

sudo mkdir /etc/hal/fdi/preprobe

sudo mkdir /etc/hal/fdi/information

/usr/sbin/hald --daemon=yes --verbose=yes

rm -rf ~/.adobe

I got an error the first time I copy and paste this line

/usr/sbin/hald --daemon=yes --verbose=yes

But once I installed hal and run hald it worked.

I can watch amazon prime video using Firefox.

  • not for 13.04 raring ringtail..
    – Nil
    May 2, 2013 at 4:55
  • Thanks I forgot I am running 12.10 in my laptop. Reposted what I did to make it work on 13.04
    – Sergio
    May 2, 2013 at 5:25
  • This worked for me. Renaming/deleting the old Adobe folder did the trick (after installing and making the modifications to HAL).
    – kmgdev
    May 20, 2013 at 3:14

As of today, April 27, 2013, I have found no other solution to watching Amazon Prime instant videos on Ubuntu aside from the following:

  1. Install Wine from the Ubuntu repository.
  2. Install the latest version of Firefox for Windows using Wine. The version of Wine I used was 1.4.1. I have noticed no bugs when doing so.
  3. Download the Windows installer for latest version of Adobe Flash Player and run it using Wine. I noticed no bugs when doing so.

When playing videos on Amazon Prime, I notice no artifacts or anything that would detract from the viewing experience. Even with the extra layer of compatibility, it runs just as if it were native. If another solution appears in the future that doesn't require Wine, I will update that as the correct answer.

  • you're using the version of Wine straight from the Ubuntu repos, right?
    – strugee
    Apr 28, 2013 at 4:50
  • 1
    @strugee yeah..
    – Nil
    Apr 28, 2013 at 17:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .