I've installed Skype, but the icon is not shown at the top panel (tray). As "tray-whitelist" was removed from dconf, I can't add icon by myself.

  • 1
    It should be present under the messaging menu, which makes it easy to access and view all email and chat clients. However, if you don't like it, sni-qt:i386 is the way to go Jul 18, 2013 at 14:43
  • @Vic It is not duplication, since another answer works only in < 12.10. In 13.04 "tray-whitelist" was removed. That's why your one won't help on systems >=13.04 Sep 17, 2014 at 17:28

5 Answers 5


I had the same problem, installing the following package fixed it for me:

sudo apt-get install sni-qt:i386

I had the same problem when I downloaded skype directly from skype.com.

To fix it just you need completely remove your installed skype, then open terminal and do this:

  1. sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
  2. sudo apt-get update
  3. sudo apt-get install skype && sudo apt-get -f install

After these manipulations I have skype icon in panel.

  • Its always a bit older version, but a good solution to a given problem
    – Michael
    Jul 3, 2013 at 8:09

Skype icon can be visible after white listing the skype icon by gsetting set command like,

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Wine', 'Update-notifier', 'Skype']"

Found on Linuxicle : Enable skype notification icon in Ubuntu 12.04/13.04

  • 1
    This worked for me. Thanks. (Using Ubuntu 12.04.4)
    – alexscmar
    Feb 12, 2014 at 14:16
  • From Ubuntu 13.04 on, this solution will not work as the support for systray-whitelist was removed (see). You can however install the systray-white PPA's packages to make this solution work again.
    – tanius
    Feb 17, 2014 at 17:13

This have worked for me: http://www.webupd8.org/2013/04/fix-skype-not-working-in-ubuntu-1304.html Nvidia and Catalyst drivers don't run well with skype.


I also had problems installing Skype from skype.com. I had tried to install the Ubuntu 12.04 multiarch version that seemed to be the closest they had to the one I was running which was Ubuntu 13.04 on a x86_64 (64 bit) machine. Had problems with both the sound and video and my 13.04 was a clean and recent install.

I then completely uninstalled that version and took the version from canonical.com and have now managed to successfully use Skype.

Not the answer you're looking for? Browse other questions tagged or ask your own question.