I just upgraded to 13.04 from 12.10 and now I'm having trouble with my bluetooth mouse (dell BT travel mouse).

It used to work without probs in 12.10. Now I can add the mouse as a bluetooth device in ubuntu and it will work. but after a couple of minutes the pointer will stop moving. The bluetooth settings show the mouse as being connected but it just doesn't work anymore. if I remove the device and then try to add it again it will not connect.

All I can do is remove the device. Reboot. Then add it again. This makes it work for a couple of minutes again and then it will stop working.

I don't know what they changed in 13.04 but as I said it worked fine before.

Any ideas? Thanks a lot!


I had the same problem with my MS Bluetooth Mouse 5000 that directly connects to my laptops internal Bluetooth Adapter 4.0. After a seemingly random time the mouse stop working despite being shown as connected in Bluetooth settings. I found that this seems to be related to the powersavings configuration. I use tlp (see first answer: info about tlp), and in powertop I saw that all USB devices' powersaving options are enabled. The problem seems to be, that after the powersave option kicks in, the mouse won't reconnect anymore, so the core of the problem must be there. However, this work-around worked for me now:

1.) I used lsusb to determine the ID of my bluetooth device (I wonder why bluetooth counts as usb-device?):

username@laptop:~$ lsusb
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 003 Device 002: ID 041e:3042 Creative Technology, Ltd 
Bus 003 Device 003: ID 8087:07da Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

This website helped me to identify which ID is bluetooth: identify USB IDs In my case that was Bus 003 Device 003: ID 8087:07da Intel Corp.

2.) Then I used the ID: 8087:07da to blacklist the power saving option in tlp:

Open the tlp configuration file using the terminal: gksu gedit /etc/default/tlp and search the line containing: USB_BLACKLIST= Then edit this line and enter the ID of the bluetooth device, e.g. in my case: USB_BLACKLIST="8087:07da"

After restart, the Bluetooth my did not disconnect anymore and in powertop, Tunables I see that powersave options for this ID are disabled.

  • I have 05ac:8213 Apple, Inc. Bluetooth Host Controller and 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth), which one should I blacklist? – euDennis Mar 15 '14 at 22:19
  • @euDennis it has been a while since I answered this question, but I think I used a web page to find which addresses belong to which hardware. – cuichi Mar 18 '14 at 16:39
  • This solution worked perfectly with a thinkpad bluetooth keyboard that kept disconnecting and reconnecting. Ubuntu 14.04 and tlp. – sunew Mar 18 '15 at 23:24

After upgrading to 13.04 my mouse (MS BT Notebook mouse 5000) worked just fine with unity. Then I started using Gnome shell and gdm and the same mouse problems appeared. I switched between unity and gnome-shell but that did not helped. Then I switched back to using lightdm and the mouse problems disappeared. So for me lightdm + unity or gnome shell makes bt mouse work just fine.

  • i don't use gnome shell at all. just unity. – Nic May 19 '13 at 7:29

I had a problem with Apple Magic mouse disconnecting randomly. The solution might also apply to other bluetooth mouse problems. See https://askubuntu.com/a/629495/80997 .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.