i have upgraded Ubuntu desktop from 12.10 to 13.04. Since then I can't see the Panel or Launcher, but I'm able to open the terminal using the keyboard shortcut Ctrl+Alt+T.

When I use the Guest login there is no such problem. I am facing the problem only with administrator account. I have tried this Launcher, top Panel, and window decorations missing after 12.04 upgrade, but I couldn't find the result.


4 Answers 4


This worked for me:

dconf reset -f /org/compiz/ 

then enter:

unity --reset-icons &disown
  • this works, but keep in mind that it will reset the launcher!
    – maephisto
    Aug 14, 2013 at 10:32
  • this did not work for me. The menus appeared for a second, after the restart, then disappeared.
    – dranxo
    Oct 31, 2013 at 0:20
  • works when I run like that dconf reset -f /org/compiz/ && unity --reset-icons &disown at the second time. Dec 17, 2013 at 22:30
  • I just login with root account in ubuntu-14.04 LTS then i can not see anything in topbar its just black panel. then i can not do anything with launcher. i have reset unity tweak tool but all try failed. can anyone help? May 12, 2015 at 6:16

Try deleting ~/.cache or~/.gconf. Realize however that if you made any edits to the system using dconf (or gconf)-editor, they will be reset.

Another alternative is to also delete ~/.config but that would reset any and all application preferences throughout Ubuntu for your user.

See also: Resetting Unity on 12.10 or 13.04


try this:

sudo apt-get purge fglrx lightdm && sudo apt-get install lightdm ubuntu-desktop

and then reboot


This happened to me and I moved the .config directory and re-logged in and it is working fine for me now.

mv ~/.config ~/.config_old

I had to use the old Ctrl+Alt+F1 to get to a terminal because the guest terminal wouldn't allow me to sudo for some reason. Then I did a Ctrl+Alt+F7 to get back to my login session.

  • 2
    This will erase user configuration files for A LOT of programs. Don't do it unless you are sure. I would downvote but I don't have enough reputation. Jul 18, 2013 at 10:37
  • 1
    Deleting ~/.config did the trick for me.
    – Bram
    Aug 13, 2013 at 3:42

Not the answer you're looking for? Browse other questions tagged .