0

When I boot to the login screen, I can put in my credentials but nothing happens after that. I left my laptop over night and it still didn't log in. The only thing I can do is hit ctrl, alt f2 to get a terminal and run startx which required me to install gnome shell (ugh). If I run startlxde, I get an error saying that it can't connect to the display.

Edited: It seems the issue is with lxdm. LightDM allows me to login just fine.

  • Are you able to log in with command line. – shashank singh Apr 26 '13 at 16:24
  • It happens to me too. When I enter my credentials the system does nothing, no disk/process activity. startx works though. – R. Max Apr 30 '13 at 4:16
1

Try using lightdm instead of lxdm as display manager. That worked for me.

Although I can't explain why it fails with lxdm, only found some "cannot connect to X" messages at .cache/lxsession/LXDE/run.log.

  • Hey cool switching to lightdm worked well. Now to figure out what the hell is wrong with lxdm. – Rob Fitz May 1 '13 at 12:11
-1

Try:

Ctrl + Alt + F1 and log in.

sudo mv -v .Xauthority .Xauthoritybak
sudo shutdown now -r

It should now work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.