This question already has an answer here:

A new release of Ubuntu brought a new mouse settings window. However, it only lists a sensitivity setting, no acceleration. Where is the setting for acceleration? How do I disable it?

If I disable acceleration using xinput (e.g. xinput --set-prop 15 270 1, which sets the acceleration multiplier to 1) it returns if I disconnect and reconnect my mouse, and also if I reboot. Any way around this?

marked as duplicate by Braiam, Jorge Castro, BuZZ-dEE, Eric Carvalho, Achu Dec 6 '13 at 9:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Have you tried using xinput? Such as:

  • xinput --list
  • xinput --list-props #deviceid
  • xinput --set-prop #deviceid #propid value
  • 1
    description says he used: xinput --set-prop <deviceid> <propid> <value> where deviceid=15 propid=270 and value=1 – xordon Sep 18 '13 at 5:33

to survive reboot, first, create script:

echo -e '#!/bin/bash\nxinput --set-prop 15 270 1' > mouse_acceleration_1.sh

make it executable:

chmod +x mouse_acceleration_1.sh

then run

gnome-session-properties

and add this script to the list.

(I've found this answer here: Reduce the Mouse Sensitivity)

It probably won't work if you reconnect your mouse.

If your mouse moves too slow after disabling mouse acceleration you can use the following script. It (ab)uses the 'simple' acceleration profile since the xinput constant deceleration setting cannot be used for values between 0 and 1.

#!/bin/bash

device="Dell Dell USB Optical Mouse"
resolution_percent="241" # Greater than 100, use constant deceleration otherwise with profile -1. 

xinput set-prop "$device" "Device Accel Profile" 4 # Simple profile with threshold 0 allows constant scaling up
xinput set-ptr-feedback "$device" 0 "$resolution_percent" 100 # Set threshold to 0 and acceleration to $resolution_percent/100

You'll have to modify the script by using your particular device name. You can look that up by running xinput without arguments. Also the script has to be run each time the mouse is connected or when you start the system.

Not the answer you're looking for? Browse other questions tagged or ask your own question.