I just installed Ubuntu 13.04 on my media PC, and I successfully installed Catalyst 13.4 and everything works great except I get no sound out of HDMI out. In the sound dash there are 3 options but none make any difference: there is digital output (S/PDIF) ,headphones, and analogue output. Any help is appreciated. Thank you in advance.


It's bug https://bugs.launchpad.net/bugs/1169761

The kernel team introduced this by picking and choosing patches. The generic 3.8 kernel doesn't have it, and Ubuntu 13.04 kernels older than a mid-April are also ok.

I'm sure this is getting a lot of attention since it affects so many.

| improve this answer | |
  • So this will be dixed by an update? or will i have to change my kernel?, and thankyou this does seem to be my issue – Jamie Apr 27 '13 at 7:41
  1. Don't downgrade your kernel
  2. Keep the line GRUB_CMDLINE_LINUX="radeon.audio=1" in /etc/default/grub
  3. Run: sudo update-grub, and
  4. Restart the system.

This worked for me. HDMI sound showed up in the sound output panel.

| improve this answer | |

I don't know if it is the problem you are facing, but there is a bug in kernel (see here and here) that makes sound card driver crash on boot. To verify if it is indeed the same problem, check in var/log/syslog for something like this:

 BUG: unable to handle kernel paging request at <address>

This should be fixed in the following days/weeks. Meanwhile you can try to install the latest drivers as suggested in the bug report (worked for me):

Sorry for not posting a direct link to the file, but as this is a daily build probably the link would quickly become broken.


Just to point out: as this is a daily build (Ubuntu packages are recreated daily), depending on the time you check that page the .deb may not be available. If this happens you will have to check again later.

| improve this answer | |
  • thankyou, when i am next able i will check for that :) – Jamie Apr 26 '13 at 13:33
  • @Jamie did it work? – Salem May 14 '13 at 20:40
  • Yar. Installing the daily build did not fix it for me. I can still see the audio levels moving in pulseaudio, but I just can't get sound coming out of my speakers (my USB headset works fine). The sound effects in the Sound Properties panel worked for a second yesterday...but only for a second. – Alex K May 17 '13 at 18:32

Downgrading to linux kernel solves the problem.

  1. Keep the line GRUB_CMDLINE_LINUX="radeon.audio=1" in /etc/default/grub
  2. When starting the system, in GRUB2 menu, select "Advanced options" and some old linux kernel to start (3.5.0-30-generic in my case).
  3. If the sound works, remove the files of the 3.8 linux kernel from the /boot directory (need sudo).
  4. Run: sudo update-grub
  5. Restart the system

It worked in my case, however ymmv.

| improve this answer | |

Thanks to everyone.

What worked for me:

setup: Ubuntu 13.04 with ATI Radeon 4650

symptom: no sound from HDMI to TV (also didn't see HDMI output in 'Sounds' manager


  1. GRUB_CMDLINE_LINUX="radeon.audio=1" in /etc/default/grub
  2. sudo update-grub
  3. Go to ALSA daily build snapshots
  4. Select "Raring" in Series;
  5. In "Package Files" download the .deb file, install
  6. restart

You should see 'HDMI/ DisplayPort" in the All Settings | Sound gui. Audio works at this point.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.