This was an issue with moving to 12.10 it appears to have resurfaced now with 13.04 i.e. post upgrade to 13.04 you still get the MOTD to upgrade.

I've tried the previous list of fixes for the same issue re move to 12.10 https://askubuntu.com/questions/253844/upgrade-12-04-2-lts-to-12-10-do-release-upgrade-fails-no-new-release-found but they don't seem to work, i.e. there is no /var/lib/update-notifier/release-upgrade-available to remove.

2 Answers 2


I just "touch" the file /var/lib/ubuntu-release-upgrader/release-upgrade-available

But don't know why this file will not refresh automatically.

  • Can you elaborate what you mean by "touch"?
    – duxk.gh
    Apr 28, 2013 at 9:42
  • 1
    @duxk.gh either remove only the contents of the file; or do sudo su and then cd /var/lib/ubuntu-release-upgrader; rm release-upgrade-available; touch release-upgrade-available.
    – Cetin Sert
    Apr 30, 2013 at 0:07
  • 4
    Just remove the file /var/lib/ubuntu-release-upgrader/release-upgrade-available, forget the touch (/etc/update-motd.d/91-release-upgrade will recreate it when needed). May 1, 2013 at 11:40

In a similar situation I found that there is another file /run/motd.dynamic apart from /run/motd and the old message persisted /run/motd. Both are called by pam_motd which states that /run/motd is static.

# This includes a dynamically generated part from /run/motd.dynamic
# and a static (admin-editable) part from /etc/motd.

The solution was just to empty the static file:

echo -n "" | sudo tee /run/motd

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.